The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

oh noes, forbiddon 403! :(

Discussion in 'General Discussion' started by eryk, Jul 26, 2007.

  1. eryk

    eryk Member

    Joined:
    Jul 17, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    hello guys,

    i did something very stupid... not sure what, but everytime i load my site i get a:

    ---------
    Forbidden
    You don't have permission to access / on this server.

    Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
    ---------

    i ran a search, but nothing that has helped yet

    i think i screwed something up by CHMOD, i tried to undo it, but it doesnt work :(
    most of the directories on my server are owned by me, but there was one owned by "99" whatever that means, and i was trying to change that.

    any ideas whats wrong?
     
  2. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    If you have an Index page with the correct permissions & ownership but still get the error, then yes, you have screwed something up somewhere. Don't worry though, we all have at one time or another. ;)

    Easiest solution is to Terminate the account then restore from backup.
     
  3. nyjimbo

    nyjimbo Well-Known Member

    Joined:
    Jan 25, 2003
    Messages:
    1,125
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    New York
    Well CHMOD and CHOWN are very different so it depends on what you ran and with what switches.

    At the very least check to see what the permissions are for the "public_html" folders and if the files inside are owned by the account owner and the web server group account.

    At least post the owner:group or the permissions for something so we can get an idea where you stand.
     
  4. dom974

    dom974 Active Member

    Joined:
    Jun 24, 2007
    Messages:
    41
    Likes Received:
    0
    Trophy Points:
    6
    If it is a php page you're trying to load, make sure you didn't put -ExecCGI in your .htaccess

    Dominique
     
  5. eryk

    eryk Member

    Joined:
    Jul 17, 2007
    Messages:
    6
    Likes Received:
    0
    Trophy Points:
    1
    my index.html is 755 if that means anything?

    however i cant load my joomla site either :(

    and of course, me being the noob, i dont have backups! ugh.
     
  6. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Wouldn't hurt to check the permissions of public_html itself, make sure you own it and that it has proper permissions.
     
  7. DaveUsedToWorkHere

    DaveUsedToWorkHere Well-Known Member

    Joined:
    Dec 28, 2001
    Messages:
    689
    Likes Received:
    1
    Trophy Points:
    18
    Also, check your .htaccess in public_html and make sure httpd.conf is pointing to the right webroot
     
  8. Website Rob

    Website Rob Well-Known Member

    Joined:
    Mar 23, 2002
    Messages:
    1,506
    Likes Received:
    0
    Trophy Points:
    36
    Location:
    Alberta, Canada
    cPanel Access Level:
    Root Administrator
    Change your 'index.html' to 644 permissions.

    A shame you didn't have Backups enabled but hopefully now you do.


    As mentioned already, we need to start at the source to figure out this problem.

    What is the result of this command: ls -lh /home/accountID where 'accountID' is the problem account?
    We are looking for permission settings of the 'public_html' dir. only, which should be 750 and look something like this:
    drwxr-x--- 21 accountID nobody 4.0K Jul 18 14:52 public_html/

    Also, have you asked your DC if they will help you with this problem? Most will.
     

Share This Page