Old MySQL client version, how do I update?

internetfab

Well-Known Member
PartnerNOC
Feb 20, 2003
336
0
166
Gothenburg, Sweden
cPanel Access Level
DataCenter Provider
Hi all,

Just noticed that one of our servers running MySQL 5.0.27 states that the client version is 4.1.10 in phpmyadmin. Ran a yum info on MySQL-client and it says 5.0.27 installed.

Searched through a few threads here and one mentioned a full removal of all rpm's and a forced update of Mysql.

Tried just running a mysqlup --force but that didn't help at all. I also tried a mysql_upgrade but the check got stuck on:

Code:
ERROR 1060 (42S21) at line 22: Duplicate column name 'File_priv'
Otherwise all seems fine, databases are working and this server has been running mysql5 from the beginning (well since first upgrade after a standard cpanel install).

Any idea how to get the client up to version 5.0.27?
 

internetfab

Well-Known Member
PartnerNOC
Feb 20, 2003
336
0
166
Gothenburg, Sweden
cPanel Access Level
DataCenter Provider
phpmyadmin reports wrong mysql client version

Ok, I guess Im a bit confused here.

phpinfo reports that the client version is indeed 5.0.27 but phpMyAdmin reports client version 4.1.10. Is there a setting in phpmyadmin that I need to update OR is the a local cPanel mysql client somewhere?

The error that I got in the first post can be dismissed since it just means that the database structure has already been updated.

So it just seems that phpmyadmin is having this error... help anyone?
 

internetfab

Well-Known Member
PartnerNOC
Feb 20, 2003
336
0
166
Gothenburg, Sweden
cPanel Access Level
DataCenter Provider
Found the culprit..

phpmyadmin through cPanel uses cPanel's own PHP installation which is php 4.4.2, therefor it uses an old client.
Tried an update to latest current - no change. Is it possible to update the cPanel php version without breaking things? Is there a way to do it through WHM or /scripts?
 

Shelly

Registered
Aug 19, 2006
3
0
151
I'm so glad to see your posts.

It's just what I want to ask.

Hopefully someone can help us.

Attachment is the phpMyAdmin interface which shows 2 different MySQL version.
 

Attachments

internetfab

Well-Known Member
PartnerNOC
Feb 20, 2003
336
0
166
Gothenburg, Sweden
cPanel Access Level
DataCenter Provider
I found where you can change this - but I'm not sure what kind of consequences it might have on cPanel's functions. Im guessing none but have decided not to change it manually anyway.

If you'd like to change it, you can do this: (if for example you want it to use MySQL5 client instead of MySQL4 client)

Code:
mv /usr/local/cpanel/lib/libmysqlclient.so.14 /usr/local/cpanel/lib/libmysqlclient.so.14.backup
ln -s /usr/lib/libmysqlclient.so.15.0.0 /usr/local/cpanel/lib/libmysqlclient.so.14
Use at your own risk :)
 

ambrish

Member
Dec 9, 2006
6
0
151
Mumbai
It may be help you

>>Is it possible to update the cPanel php version without breaking things? Is there a way to do it through WHM or /scripts?
/scripts/mysqlup {If it not work as you mention earlier}
try
/scripts/upcp --force
It updates without breaking things?
If you are using old scripts then try to use mysql 4.x.x otherwise 5.x.x...

:)
 

bornonline

Well-Known Member
Nov 19, 2004
139
0
166
Earth
I noticed this today too.

In phpmyadmin
Server version: 5.0.45-community
MySQL client version: 4.1.22

So, guess we wait or has anyone tried interfab fix? :D
 

apn3a

Member
Oct 25, 2007
15
0
51
apparently not.. i have the same exact problem. anyone can think of a solution please?
 

apn3a

Member
Oct 25, 2007
15
0
51
I found where you can change this - but I'm not sure what kind of consequences it might have on cPanel's functions. Im guessing none but have decided not to change it manually anyway.

If you'd like to change it, you can do this: (if for example you want it to use MySQL5 client instead of MySQL4 client)

Code:
mv /usr/local/cpanel/lib/libmysqlclient.so.14 /usr/local/cpanel/lib/libmysqlclient.so.14.backup
ln -s /usr/lib/libmysqlclient.so.15.0.0 /usr/local/cpanel/lib/libmysqlclient.so.14
Use at your own risk :)
unfortunately that did not work for me. After doing that (changed the path you are suggesting to lib64 since i use centos 5 64bit) i receive the following 500 error when i try to access phpmyadmin:

Internal Server Error

Premature end of script headers: php: Please check /usr/local/cpanel/logs/error_log for the exact error.

Also the error log shows:

/usr/local/cpanel/3rdparty/bin/php: /usr/local/cpanel/lib64/libmysqlclient.so.14: version `libmysqlclient_14' not found (required by /usr/local/cpanel/3rdparty/bin/php)
Internal Error: "GET /3rdparty/phpMyAdmin/index.php HTTP/1.1" Premature end of script headers: php: Please check /usr/local/cpanel/logs/error_log for the exact error.

i had to reverse the process to make phpmyadmin to work again. any more ideas?
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
308
cPanel Access Level
Root Administrator
unfortunately that did not do the trick either. i still get:

MySQL client version: 4.1.21
Used PHP extensions: mysql


in phpmyadmin. :( any more suggestions?
My apologies, I mis-read the threading, thinking you had already removed all the MySQL 4 related RPMs and files.

What is your cPanel version?
 

apn3a

Member
Oct 25, 2007
15
0
51
My apologies, I mis-read the threading, thinking you had already removed all the MySQL 4 related RPMs and files.

What is your cPanel version?
my cpanel/whm version is: WHM 11.15.0 cPanel 11.18.1-R20683 Release.


also, after running /scripts/makecpphp, cpanel now says i have PHP version 5.2.3 on the left side. However, all the software i am using says that im running PHP 5.2.5 (which i had install from ea prior the makecpphp). Do i need to re-run ea to update cpanel's php version or there is something else wrong? Because before i run /scripts/makecpphp cpanel was showing PHP version 5.2.5.

thanks!
 

cPanelKenneth

cPanel Development
Staff member
Apr 7, 2006
4,608
77
308
cPanel Access Level
Root Administrator
my cpanel/whm version is: WHM 11.15.0 cPanel 11.18.1-R20683 Release.


also, after running /scripts/makecpphp, cpanel now says i have PHP version 5.2.3 on the left side. However, all the software i am using says that im running PHP 5.2.5 (which i had install from ea prior the makecpphp). Do i need to re-run ea to update cpanel's php version or there is something else wrong? Because before i run /scripts/makecpphp cpanel was showing PHP version 5.2.5.

thanks!
The profile used by makecpphp defaults to PHP 5.2.3. There are a couple options available to you:

1. Modify /scripts/makecpphp.profile.yaml to use PHP 5.2.5 (entry looks like Cpanel::Easy::PHP5::2_5)
2. Use the system installed PHP (rm /var/cpanel/usecpphp)

Only with option 2 will a normal EA3 build update the PHP version used by cPanel.
 

apn3a

Member
Oct 25, 2007
15
0
51
The profile used by makecpphp defaults to PHP 5.2.3. There are a couple options available to you:

1. Modify /scripts/makecpphp.profile.yaml to use PHP 5.2.5 (entry looks like Cpanel::Easy::PHP5::2_5)
2. Use the system installed PHP (rm /var/cpanel/usecpphp)

Only with option 2 will a normal EA3 build update the PHP version used by cPanel.
thanks that did the trick.

About the mysql issue, for some reason it was solved after i rebuild apache and php. thanks again!
 
Last edited: