The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

OMG I cannot get my sites up

Discussion in 'General Discussion' started by shanit, Dec 20, 2005.

  1. shanit

    shanit Well-Known Member

    Joined:
    Dec 18, 2005
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    I have been trying and trying but i keep having errors with http restarting it keeps failing I dont know what to do can any help I been trying to build it but i keep getting errors saying failed httpd i think it has a d on it lol any help would really be appreciated i'm using linux

    WHM 10.8.0 cPanel 10.8.1-R10
    RedHat Enterprise 3 i686 - WHM X v3.1.0
    hope that helps you help me ;)

    Thanks
    shannon
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    You need to post any errors that you see in the apache error_log when you start it.
     
  3. shanit

    shanit Well-Known Member

    Joined:
    Dec 18, 2005
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    ok this is the whole page after doing apache update
    Building Apache Config.....Done
    Downloading and compiling apache+modules....


    Verifying archive integrity... All good.
    Uncompressing buildapache................................................................................................................................
    Verifying compiler and libs....Verifying installation....Done
    Done
    ********************************
    This is buildapache version 10.8.1
    ********************************
    buildapache configured from Web Host Manager
    Apache configured from Web Host Manager!
    /etc/rc.d/init.d/httpd start: httpd could not be started
    Setting /home permissions to 0711......Done
    Setting permissions for.....sunshine...xrated...b000h...badss...banner...bbw...chevyauc...auctinfo...chevyran...store...knox...leo...leoshost...random...pleasure...purepaym...babyhost...sexyass...shannons...triplex...usick...camz...shanit...blueskye...cashema...moneytre...motor...sanddoll...starryni...wwwd...cashemai...emailspa...payaddic...friendly...hotrod...temp123...whmdemo...hostdemo...bangme...hostingf...cashpaym...h4ptr...hosting4...hot4u...hotthost...justhow...ratemy...software...keiskooo...best...best1...buyebook...canicash...cashnugg...cashola...cashprof...ebooks...fastlogo...forrand...free...freelanc...guarante...gtraffic...hits4me...hotebook...hot2trot...hotfree...hottraff...hottraf1...isell...linkx...mygame...mygames...traffic4...wantcash...whm...yourcash...cute...thetruck...svcdplaz...little...your......Done
    Untarring curl......Done

    configure curl-7.12.0...(--prefix=/usr).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done

    make -j 2 curl-7.12.0....... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done

    make curl-7.12.0...(install).... . . . . . . . . Done
    Untarring php....Done
    Applying CURL curl_formfree patch
    patching file ext/curl/curl.c
    Hunk #1 succeeded at 590 (offset 45 lines).
    Hunk #2 succeeded at 904 (offset 19 lines).

    configure php-4.4.1...(--with-apxs=/usr/local/apache/bin/apxs --prefix=/usr/local --with-xml --enable-bcmath --enable-calendar --with-curl --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --enable-magic-quotes --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --enable-versioning --with-zlib).... . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . . Done

    make -j 2 ...(clean)...

    make -j 2 php-4.4.1....... Done

    make php-4.4.1...(install).... Done
    /etc/rc.d/init.d/httpd start: httpd could not be started

    configure php-4.4.1...(--prefix=/usr --with-xml --enable-bcmath --enable-calendar --with-curl --enable-ftp --with-gd --with-jpeg-dir=/usr/local --with-png-dir=/usr --with-xpm-dir=/usr/X11R6 --enable-magic-quotes --with-mysql=/usr --enable-discard-path --with-pear --enable-sockets --enable-track-vars --enable-versioning --with-zlib).... Done

    make -j 2 php-4.4.1...(clean).... Done

    make -j 2 php-4.4.1....... Done

    make php-4.4.1...(install).... Done
    initfpsuexec: using apache 1.x support
    PHP version file has been updated to 4.4.1
    Executing /scripts/postbuildapache (if exists)...Done
    /etc/rc.d/init.d/httpd start: httpd could not be started
    Attempting to restart httpd
    Waiting for httpd to restart....
    .
    .
    .
    .
    .
    .
    .
    .
    .
    .
    finished.


    httpd status



    httpd has failed, please contact the sysadmin.
    Build Complete
     
  4. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    As I said, you need to post any errors that you see in the apache error_log. It's at /usr/local/apache/logs/error_log
     
  5. shanit

    shanit Well-Known Member

    Joined:
    Dec 18, 2005
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    oh ok i miss understood sorry hang on ill look
     
  6. shanit

    shanit Well-Known Member

    Joined:
    Dec 18, 2005
    Messages:
    46
    Likes Received:
    0
    Trophy Points:
    6
    I really dont know what to paste on here cause I"m new to this log i never even knew how to find it thank you :) i will paste i guess from about 2am lastnight til current now

    ok dang i have looked and it goes from OCT to december 15 thats it and I just got it 10 days ago

    I'm going to email spry i guess cause

    they have to fix it with out me paying extra for support cause it just stopped working and theres no logs

    Is there another way to find logs?

    Thanks
    Shannon
     
  7. parasane

    parasane Well-Known Member

    Joined:
    Oct 19, 2003
    Messages:
    48
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Dickson City, Pennsylvania (USA)
    Shannon,

    The logs you need to find should be in one of the following three places, by order of likelihood:

    /usr/local/apache2/logs/error_log
    /usr/local/apache/logs/error_log
    /var/log/httpd/error_log

    Check those out and see what you come up with.

    ~ Dan
     
  8. Planet_Master

    Planet_Master Well-Known Member

    Joined:
    Apr 18, 2002
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    New Yorker
    Good chance the httpd.conf is corrupt or misconfigured, try a file rollback from just before when the problems started, its worth a shot.
     
  9. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    No, the log is highly unlikely to be in the first, will not be in the last, and is in the second where I said.
     
Loading...

Share This Page