"On behalf of" added to the sender mail address

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,216
11
313
Houston, TX
cPanel Access Level
Root Administrator

jarodlwk

Active Member
Sep 24, 2006
40
0
156
Yes, it only appears in Outlook. In webmail it is fine. Is it an Outlook problem? I don't have this before the upgrade.
 

cPanelDavidG

Technical Product Specialist
Nov 29, 2006
11,216
11
313
Houston, TX
cPanel Access Level
Root Administrator
Playing around with the Exim Configuration Editor today in WHM, I found the following setting you may wish to uncheck if you want to remove the "on behalf of" in Outlook:

** Always set the "Sender:" header when the sender is changed from the actual sender. Unchecking this will stop "On behalf of" data in Microsoft® Outlook, but may limit your ability to track abuse of the mail system.

You can do this in WHM -> Service Configuration -> Exim Configuration Editor
 

jarodlwk

Active Member
Sep 24, 2006
40
0
156
It was unchecked all the while. This only happens when mails are sent from Mailman distribution list.