Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

One or no Content-Type headers, not 2

Discussion in 'E-mail Discussions' started by Motester, Mar 20, 2018.

  1. Motester

    Motester Registered

    Joined:
    Mar 20, 2018
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Website Owner
    Hi,
    I'm hoping someone can help with this.

    Confirmation mail to our website users is being returned with:

    host outbound.mailspamprotection.com [96.127.xxx.xxx]
    SMTP error from remote mail server after end of data:
    550 Messages should have one or no Content-Type headers, not 2.

    We are receiving the associated Admin emails (which are on a local server/domain) but the user, on any other domain, receives nothing. We've tried testing with many different domains, nothing gets through.

    We have tried with and without an SMTP mailer, and our ISP says it is not their problem, but originates within the Wordpress/plug-in installation.

    Is it possible to find out what is adding the headers and prevent it? Would that fix it, or just move the problem somewhere else?

    Many thanks
     
    #1 Motester, Mar 20, 2018
    Last edited by a moderator: Mar 20, 2018
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,734
    Likes Received:
    1,706
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Can you verify if any specific entries appear in /var/log/exim_rejectlog or /var/log/exim_mainlog during the failed delivery attempt?

    Thank you.
     
  3. Motester

    Motester Registered

    Joined:
    Mar 20, 2018
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Website Owner
    Support at the ISP says:
    "In the reject logs there is no information about emails that are rejected as the entries inside are not relevant. In the main exim log however there are records about the emails that are bounced:
    Code:
    Code:
    2018-03-20 07:36:46 1eyGVS-0000zX-0d <= s***@*****.co.uk H=(www.*****.co.uk) [109.199.116.136]:51634 P=esmtpsa X=TLSv1.2:ECDHE-RSA-AES128-GCM-SHA256:128 CV=no A=dovecot_login:***@****.co.uk S=2837 id=fb8cf068098b1d52416b8d6f5a6f6606@www.******.co.uk T="[XXXXX] Listing Claim Request Approved" for j****_75@hotmail.com
    2018-03-20 07:36:46 cwd=/var/spool/exim 3 args: /usr/sbin/exim -Mc 1eyGVS-0000zX-0d
    2018-03-20 07:36:49 1eyGVS-0000zX-0d ** j****_75@hotmail.com R=se_lookuphost T=remote_se_smtp H=outbound.mailspamprotection.com [184.154.XX.XXX] X=TLSv1.2:ECDHE-RSA-AES256-GCM-SHA384:256 CV=yes: SMTP error from remote mail server after end of data: 550 Messages should have one or no Content-Type headers, not 2.
    2018-03-20 07:36:49 cwd=/var/spool/exim 7 args: /usr/sbin/exim -t -oem -oi -f <> -E1eyGVS-0000zX-0d
    2018-03-20 07:36:49 1eyGVV-0000zq-Kg <= <> R=1eyGVS-0000zX-0d U=mailnull P=local S=4368 T="Mail delivery failed: returning message to sender" for s***@******.co.uk
    2018-03-20 07:36:49 1eyGVS-0000zX-0d Completed
    
    The information in the logs don't provide any useful information about what actually causes the issue."

    Attached file may also shed some light.

    e17c4820-c5af-4d86-881a-4d1542ec7875.JPG
     
    #3 Motester, Mar 20, 2018
    Last edited by a moderator: Mar 21, 2018
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    42,734
    Likes Received:
    1,706
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    The information you provided suggests there's an issue with the WordPress plugin you are using to send the email. It suggests the plugin is adding multiple "TO" entries in the message header. Have you reported this to the WordPress plugin developer to verify if it's a known issue or a bug with their plugin?

    Also, you may want to try using a different SMTP plugin to rule out the existing plugin as the source of the issue.

    Thank you.
     
  5. Motester

    Motester Registered

    Joined:
    Mar 20, 2018
    Messages:
    3
    Likes Received:
    1
    Trophy Points:
    1
    Location:
    UK
    cPanel Access Level:
    Website Owner
    Many thanks,
    We've tried without an SMTP plugin and with different SMTP plugins.
    I think you're right and it can only originate with the plugin which is originating the emails.
    Thanks again for your input.
     
    cPanelMichael likes this.
Loading...

Share This Page