magicalwonders

Well-Known Member
Nov 21, 2012
112
2
18
cPanel Access Level
Root Administrator
I have the following two errors that keep showing up in my error log on my VPS -

[Fri Sep 26 04:07:33 2014] [warn] RSA server certificate CommonName (CN) `webhost1.mydomain.com' does NOT match server name!?
[Fri Sep 26 04:07:33 2014] [emerg] mod_qos(007): could not determine MaxClients/MaxRequestWorkers! You MUST set this directive within the Apache configuration file.
I've changed the name in first error for purposes of this post, but is there anything I can edit to fix these errors?

The second error mentions the Apache configuration file, but not sure what edit to make for this issue?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,883
2,256
463
Hello :)

Have you enabled MPM Worker via EasyApache? Are you planning to use mod_qos or are you not yet sure how you plan to configure it? It's documented here:

EasyApache - Mod_QoS
mod_qos

Thank you.
 

magicalwonders

Well-Known Member
Nov 21, 2012
112
2
18
cPanel Access Level
Root Administrator
"...Have you enabled MPM Worker via EasyApache? Are you planning to use mod_qos or are you not yet sure how you plan to configure it? It's documented here:

EasyApache - Mod_QoS
mod_qos

.
I haven't heard of this stuff before. I don't know if my host has enabled MPM worker. From what I can find out the default is Prefork? (I have no idea what I'm talking about!) How do I check which one is running?

Maybe I should pass this one to my tech support. They are supposed to have set the VPS up. But it's not been without issues!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,883
2,256
463
I suggest disabling Mod_QoS in EasyApache if you are not planning on configuring it. It's not enabled by default, and thus it's not recommended unless you are comfortable making custom configuration changes. This will get rid of the warning messages you see in the Apache error log.

Thank you.
 

magicalwonders

Well-Known Member
Nov 21, 2012
112
2
18
cPanel Access Level
Root Administrator
OK thanks. So for doing that in easy apache, I do the following?

Login as root through SSH.
1) Login to your server and su - to root.

Run EasyApache
2) /scripts/easyapache

Select the options you want for your configuration
3) Type in 6 and press enter


You will be show the config options to build apache with.
4) Press space bar to select/deselect which options you want, use arrow keys to move and enter to go to sub menu.

Go to PHP module options
5) Move cursor to PHP and press enter. You will now see more options you can select.

Finishing Config options, Once you have selected your config options for Apache.
6) Exit, Exit, Yes to safe config
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,883
2,256
463
Hello,

Yes, that is correct. Ensure you deselect the QoS module.

Thank you.
 

magicalwonders

Well-Known Member
Nov 21, 2012
112
2
18
cPanel Access Level
Root Administrator
I got as far as step 3 and then it becomes a bit uncertain. I get a screen as in attached screenshot.

It seems I can toggle between 4 options. Default - Basic - MPM ITK - Mod Ruid2
The cursor is blinking on Default option, which I'm guessing is the one I want to edit? When I enter no.6 as per instructions, the cursor just keeps blinking! Is this the same thing as in entering password, where no number actually appears on the screen?

I've quit for now but will have another go if you can advise. :)
 

Attachments

Last edited: