The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Only the word "combined" is being logged in domain's domlogs

Discussion in 'General Discussion' started by nat, Feb 26, 2008.

  1. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    I recompiled apache on 02/12/2008. Since then the only thing logged in user's domain logs are "combined"

    For example, in /usr/local/apache/domlogs/username/domain.com

    combined
    combined
    combined
    combined
    combined
    combined
    etc...

    I have since recompiled apache again and it is still only logging the word "combined"
     
  2. nat

    nat Well-Known Member

    Joined:
    Jan 16, 2003
    Messages:
    204
    Likes Received:
    0
    Trophy Points:
    16
    I compared my httpd.conf with another server that was working and found a bunch of stuff missing. I added what was missing and it is now logging correctly.

    This is everything that was missing. What I think the problem was for this issue is in blue.

    <Directory "/">
    Options All
    AllowOverride All
    </Directory>

    <Directory "/usr/local/apache/htdocs">
    Options Indexes FollowSymLinks
    AllowOverride None
    Order allow,deny
    Allow from all

    </Directory>

    <Files ~ "^error_log$">
    Order allow,deny
    Deny from all
    Satisfy All
    </Files>

    <FilesMatch "^\.ht">
    Order allow,deny
    Deny from all

    Satisfy All
    </FilesMatch>

    <IfModule log_config_module>
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\"" combined
    LogFormat "%h %l %u %t \"%r\" %>s %b" common

    CustomLog "logs/access_log" common

    <IfModule logio_module>
    LogFormat "%h %l %u %t \"%r\" %>s %b \"%{Referer}i\" \"%{User-Agent}i\" %I %O" combinedio

    </IfModule>

    </IfModule>


    <IfModule alias_module>
    ScriptAlias /cgi-bin/ "/usr/local/apache/cgi-bin/"

    </IfModule>

    <Directory "/usr/local/apache/cgi-bin">
    AllowOverride None
    Options None
    Order allow,deny
    Allow from all

    </Directory>

    <IfModule mime_module>
    TypesConfig conf/mime.types
    AddType application/x-compress .Z
    AddType application/x-gzip .gz .tgz

    </IfModule>
     
  3. Stephanie_R

    Stephanie_R Active Member

    Joined:
    Mar 1, 2004
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    We are getting similar issues on our machines too. to fix it for now we are doing the following:

    A bug in the latest easyapache maybe? I'll hit up a ticket after I finish searching for any others affected and fixing them up.
     
  4. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    4
    Trophy Points:
    18
    1) Is it really in a subdirectory of the username?
    IE is it
    /usr/local/apache/domlogs/username/domain.com
    and not
    /usr/local/apache/domlogs/domain.com

    2) What is the log directive for the exact file path in question?

    It does sound like the given LogFormat is missing therefore 'combined' becomes the format of the message to log...

    Could you open a ticket as I can;t reproduce the behavior of it missing.
     
  5. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    4
    Trophy Points:
    18
    Probably should end in .c or it may never be true and hence the directives inside them never applied...
     
  6. Stephanie_R

    Stephanie_R Active Member

    Joined:
    Mar 1, 2004
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    The logs were showing the same output on our machines for both:

    /usr/local/apache/domlogs/username/domain.com
    and
    /usr/local/apache/domlogs/domain.com

    Support Request Id: 259070

    Thanks.
     
Loading...

Share This Page