The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

SOLVED OP address used for HELO

Discussion in 'E-mail Discussions' started by papazetis, Mar 17, 2017.

  1. papazetis

    papazetis Registered

    Joined:
    Mar 17, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Manchester
    cPanel Access Level:
    Root Administrator
    Hello.

    How can I fix the smtp banner to contain the Hostname and not my IP Address.

    I am using WHM 62.0 (build 16) and Roundcube for sending my emails.
     

    Attached Files:

  2. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    588
    Likes Received:
    88
    Trophy Points:
    153
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    Hello,

    Do you have a valid rDNS setup on the IP?

    You can check using dig in SSH:

    Code:
    # dig -x 172.217.8.174 +short
    Replace with your IP.

    If it is, its possible you have the following option checked in WHM > Exim Configuration

    Reference /etc/mailhelo for outgoing SMTP HELO

    If yes, go into /etc/mailhelo and make sure its set up properly like so:

    *: server.hostname.com

    or whatever is set as your rDNS
     
  3. papazetis

    papazetis Registered

    Joined:
    Mar 17, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Manchester
    cPanel Access Level:
    Root Administrator
    Yes I have setup rDNS correctly.

    My hostname is set to the the same I get from "dig -x".

    Exim Configuration is like this
    Untitled-1.jpg

    And I change /etc/mailhelo to my server rDNS but I am still getting the same error
     
  4. Jcats

    Jcats Well-Known Member

    Joined:
    May 25, 2011
    Messages:
    588
    Likes Received:
    88
    Trophy Points:
    153
    Location:
    New Jersey
    cPanel Access Level:
    DataCenter Provider
    Most likely a false positive then, as long as your server hostname is setup properly along with the rDNS, I don't see why you would be having this problem.

    Can you send yourself a test email and check the headers of the email then check the HELO manually, does it show an IP?
     
  5. papazetis

    papazetis Registered

    Joined:
    Mar 17, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Manchester
    cPanel Access Level:
    Root Administrator
    Yes it shows my server's IP in HELO
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    37,064
    Likes Received:
    1,286
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you verify if the issue persists when temporarily disabling the "Introduce a delay into the SMTP transaction for unknown hosts and messages detected as spam" option in "WHM >> Service Configuration >> Exim Configuration Manager >> Basic Editor"? I've seen reports that this option prevents third-party utilities such as MXToolBox from completing a check of the RDNS entry.

    Thank you.
     
  7. papazetis

    papazetis Registered

    Joined:
    Mar 17, 2017
    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Manchester
    cPanel Access Level:
    Root Administrator
    Thank you for your support.
    I just fix it.
    The problem was with RoundCube. I change the $config['smtp_helo_host'] to point to my rDNS.
     
Loading...

Share This Page