mahdy_sharifi

Well-Known Member
Feb 26, 2012
218
1
68
cPanel Access Level
Root Administrator
Hello :

When I increase "opcache.memory_consumption" over 1024 , webserver (litespeed) stopped and following error occur :

Fatal Error Unable to allocate shared memory segment of 1610612736 bytes: shmat: Cannot allocate memory (12)

Our server setting :

kernel.msgmnb = 65536
kernel.msgmax = 65536
kernel.shmmax = 68719476736
kernel.shmall = 4294967296


Can you help ?
Regards
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

Could you elaborate further on why you decided to increase that setting? Were you experiencing a specific issue or some type of reduced performance?

Thank you.
 

mahdy_sharifi

Well-Known Member
Feb 26, 2012
218
1
68
cPanel Access Level
Root Administrator
Hello :)

Could you elaborate further on why you decided to increase that setting? Were you experiencing a specific issue or some type of reduced performance?

Thank you.
Thanks
because We have big server and all that 1024 space now full .
also server performance not good yet .
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
You may want to consult with a qualified system administrator if you do not receive user-feedback on your optimization questions.

Thank you.
 

matt1206

Active Member
Dec 20, 2011
37
1
58
cPanel Access Level
Root Administrator
Just wanted to chime in on this, I've had the same issue this evening. Unable to allocate more than 1024 when using Litespeed

Code:
2015-08-22 19:58:55.815 [STDERR] Sat Aug 22 19:58:55 2015 (24843): Fatal Error Unable to allocate shared memory segment of 2147483648 bytes: shmat: Cannot allocate memory (12)
2015-08-22 19:58:55.825 [STDERR] Sat Aug 22 19:58:55 2015 (24844): Fatal Error Unable to allocate shared memory segment of 2147483648 bytes: shmat: Cannot allocate memory (12)