Opening port already opened in CSF issue

Gabriel Grigore

Registered
Dec 7, 2017
1
0
1
Iasi, Romania
cPanel Access Level
Root Administrator
Hello,
Tried to open a specific port (5200) for an application API. Included the port in the allowed list in csf (csf.conf) and still the port is listed as closed. Looked everywhere for information, even tried to add it to public ports via firewalld, still no success (CentOS 7, cpHulk disabled etc.).
"lsof -i" doesn't show it as listening, neither "netstat -na |grep 5200" shows it.
"iptables-save | grep 5200" results in:
-A INPUT ! -i lo -p tcp -m conntrack --ctstate NEW -m tcp --dport 5200 -j ACCEPT
-A INPUT ! -i lo -p udp -m conntrack --ctstate NEW -m udp --dport 5200 -j ACCEPT
-A OUTPUT ! -o lo -p tcp -m conntrack --ctstate NEW -m tcp --dport 5200 -j ACCEPT
-A OUTPUT ! -o lo -p udp -m conntrack --ctstate NEW -m udp --dport 5200 -j ACCEPT
Also, even with CSF dsabled, a tcptraceroute shows the port as closed. Same with iptables stopped.
I also opened a similar thread on configserver forum but with no solution from the users (the script programmers don't look there).
Is there anywhere else wher a port could be opened/blocked besides CSF?
Any ideas on how to make it public?

Thank you!
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,908
2,218
463
Hello @Gabriel Grigore,

I recommend contacting your data center or server provider to have them verify if that port is blocked from the network level.

Thank you.