The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Openssl Vulnerability

Discussion in 'General Discussion' started by mydomain, Jul 19, 2004.

  1. mydomain

    mydomain Well-Known Member

    Joined:
    Aug 10, 2003
    Messages:
    138
    Likes Received:
    0
    Trophy Points:
    16
    Hi,

    Can anyone confirm if the version of OpenSSL installed on a cPanel server (rpm -q open ssl shows openssl-0.9.7a-33.10) has fixes back-ported into it by the cPanel staff or does openssl need to be upgraded to the latest version manually?

    If it needs to be updated manually does anyone have any links on how to do this on a cPanel server as I believe the version of OpenSSL and Apache used in the buildapache process are closely related and will revert back to a previous openssl version?
     
  2. Myacen

    Myacen Well-Known Member

    Joined:
    Apr 6, 2002
    Messages:
    222
    Likes Received:
    0
    Trophy Points:
    16
    Apparently it's ok, but we compile our own anyway
     
  3. haze

    haze Well-Known Member

    Joined:
    Dec 21, 2001
    Messages:
    1,550
    Likes Received:
    3
    Trophy Points:
    38
    Cpanel isn't responsible for updating it, moreso, your OS distribution is, as long as it isn't EOL. Cpanel just uses those pre-existing tools to update most of the software. Check out your distributors changlog and that will tell you if it is patched.
     
Loading...

Share This Page