Openvz whm quota on 2nd mount

zambara

Member
Jun 10, 2008
5
0
51
Hello,

I have installed OpenVZ 6 on CentOS release 6.8 (Final). I've installed the whm/cpanel image. The configuration is like this:

2 x 512 Samsung SSD mounted as / and /home
2 x 2TB 7200 WD HDD mounted as /home2 and /backup using the script

#!/bin/bash
. /etc/vz/vz.conf
. ${VE_CONFFILE}
SRC=/vz2/storage/501/backup
DST=/backup
if [ ! -e ${VE_ROOT}${DST} ]; then mkdir -p ${VE_ROOT}${DST}; fi
mount -n -t simfs ${SRC} ${VE_ROOT}${DST} -o ${SRC}
SRC=/vz2/storage/501/home2
DST=/home2
if [ ! -e ${VE_ROOT}${DST} ]; then mkdir -p ${VE_ROOT}${DST}; fi
mount -n -t simfs ${SRC} ${VE_ROOT}${DST} -o ${SRC}

The problem is with WHM quotas.

On the SSD /home partition works fine, but on HDD /home2 partition the disk usage is not monitored.

Why can I do ?
 

Attachments

zambara

Member
Jun 10, 2008
5
0
51
Hello,

Here is the output:

[email protected] [/]# /scripts/fixquotas
Installing Default Quota Databases......Done
journaled quota support: not available with vzaquota (disabled)
Warning virtual file systems are mounted. Quotas may be counted as double
for users who are currently logged in. Please have jailshell users logout
before running quotacheck in the future!

All jailed users will be logged out in 60 seconds!

jailshell: no process killed
...
Reading package FH - Personal Advanced HDD
Resetting quota for polo to 11000 M
...

No errors
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,225
463
Hello,

Please post the output from the following commands:

Code:
mount
cat /etc/fstab
Thank you.
 

zambara

Member
Jun 10, 2008
5
0
51
Hello Michael,


Code:
[email protected] [~]# mount
/dev/simfs on / type simfs (rw,relatime,usrquota,grpquota)
/dev/simfs on /backup type simfs (rw,relatime)
/dev/simfs on /home2 type simfs (rw,relatime)
proc on /proc type proc (rw,relatime)
sysfs on /sys type sysfs (rw,relatime)
none on /dev type devtmpfs (rw,relatime,mode=755)
none on /dev/pts type devpts (rw,relatime,gid=5,mode=620,ptmxmode=000)
none on /dev/shm type tmpfs (rw,relatime)
none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw,relatime)
Code:
[email protected] [~]# cat /etc/fstab
none    /dev/pts        devpts  rw,gid=5,mode=620       0       0
none    /dev/shm        tmpfs   defaults                0       0
Hope it helps,
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,225
463
/dev/simfs on /home2 type simfs (rw,relatime)
This shows that quota isn't enabled on the /home2 partition. You should add the usrquota and grpquota options the same way it's listed for the "/" partition. I recommend contacting your VPS hosting provider for assistance with this if you are not comfortable modifying the /etc/fstab file on your system.

Thank you.
 

zambara

Member
Jun 10, 2008
5
0
51
For mounting the provider uses the command line:

Code:
mount -n -t simfs /storage2/ /vz/root/501/home2/ -o /storage2/
Can I add something to this line to mount with rw,relatime,usrquota,grpquota ?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,904
2,225
463
Hello,

You would need to use the usrquota and grpquota options after the "-o" flag:

-o usrquota,grpquota

Thank you.