The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

optimise mysql performance

Discussion in 'Workarounds and Optimization' started by crliuh, Jul 16, 2014.

  1. crliuh

    crliuh Member

    Joined:
    Jun 16, 2014
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    Hi,

    im keep getting Errcode: 24 on all my websites recently. it should be caused by over mysql usage i presume. following are the reports from mysqltuner, im not sure what i should do with the report, anyone please advise. thanks.

    Code:
     >>  MySQLTuner 1.3.0 - Major Hayden <major@mhtx.net>
     >>  Bug reports, feature requests, and downloads at http://mysqltuner.com/
     >>  Run with '--help' for additional options and output filtering
    [OK] Currently running supported MySQL version 5.5.37-cll
    [OK] Operating on 64-bit architecture
    
    -------- Storage Engine Statistics -------------------------------------------
    [--] Status: +ARCHIVE +BLACKHOLE +CSV -FEDERATED +InnoDB +MRG_MYISAM
    ERROR 23 (HY000) at line 1: Out of resources when opening file '/tmp/#sql_59ac_0.MYD' (Errcode: 24)
    [--] Data in MyISAM tables: 44M (Tables: 1562)
    [--] Data in InnoDB tables: 7M (Tables: 397)
    [--] Data in PERFORMANCE_SCHEMA tables: 0B (Tables: 17)
    [--] Data in MEMORY tables: 0B (Tables: 16)
    Argument "" isn't numeric in numeric gt (>) at ./mysqltuner.pl line 608 (#1)
        (W numeric) The indicated string was fed as an argument to an operator
        that expected a numeric value instead.  If you're fortunate the message
        will identify which operator was so unfortunate.
    
    [OK] Total fragmented tables:
    
    -------- Security Recommendations  -------------------------------------------
    ERROR 23 (HY000) at line 1: Out of resources when opening file './mysql/user.MYD' (Errcode: 24)
    [OK] All database users have passwords assigned
    ERROR 23 (HY000) at line 1: Out of resources when opening file '/tmp/#sql_59ac_0.MYD' (Errcode: 24)
    Argument "" isn't numeric in numeric eq (==) at ./mysqltuner.pl line 669 (#1)
    
    -------- Performance Metrics -------------------------------------------------
    [--] Up for: 2m 52s (4K q [26.093 qps], 22 conn, TX: 2M, RX: 715K)
    [--] Reads / Writes: 98% / 2%
    [--] Total buffers: 168.0M global + 2.8M per thread (151 max threads)
    [OK] Maximum possible memory usage: 583.2M (14% of installed RAM)
    [OK] Slow queries: 0% (0/4K)
    [OK] Highest usage of available connections: 1% (2/151)
    [!!] Cannot calculate MyISAM index size - re-run script as root user
    [!!] Query cache is disabled
    [OK] Sorts requiring temporary tables: 0% (0 temp sorts / 441 sorts)
    [!!] Joins performed without indexes: 4
    [!!] Temporary tables created on disk: 26% (299 on disk / 1K total)
    [!!] Thread cache is disabled
    [OK] Table cache hit rate: 94% (128 open / 135 opened)
    [OK] Open file limit used: 20% (209/1K)
    [OK] Table locks acquired immediately: 100% (7K immediate / 7K locks)
    [OK] InnoDB buffer pool / data size: 128.0M/7.2M
    [OK] InnoDB log waits: 0
    -------- Recommendations -----------------------------------------------------
    General recommendations:
        MySQL started within last 24 hours - recommendations may be inaccurate
        Enable the slow query log to troubleshoot bad queries
        Adjust your join queries to always utilize indexes
        When making adjustments, make tmp_table_size/max_heap_table_size equal
        Reduce your SELECT DISTINCT queries without LIMIT clauses
        Set thread_cache_size to 4 as a starting value
    Variables to adjust:
        query_cache_size (>= 8M)
        join_buffer_size (> 128.0K, or always use indexes with joins)
        tmp_table_size (> 16M)
        max_heap_table_size (> 16M)
        thread_cache_size (start at 4)
    
    thanks!
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please ensure you let MySQL run for at least 24 hours before running the tuner to obtain accurate results. Also, could you elaborate on the specific error message you are receiving?

    Thank you.
     
  3. crliuh

    crliuh Member

    Joined:
    Jun 16, 2014
    Messages:
    23
    Likes Received:
    1
    Trophy Points:
    3
    cPanel Access Level:
    Root Administrator
    this is the error i get

    when i try to perform /usr/local/cpanel/bin/update-roundcube --force

    because i've having this issue 'DATABASE ERROR: CONNECTION FAILED!' frequently in my roundcube.

    http://s24.postimg.org/58u7oka0k/Roundcube_Webmail.jpg
    [​IMG]

    and right now my websites show this error
    [​IMG]

    please help.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,854
    Likes Received:
    676
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket so we can troubleshoot those error messages. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page