Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

SOLVED "Optimize Website" (mod_deflate) refuses to enable (no error)

Discussion in 'General Discussion' started by jcwacky, Mar 3, 2017.

  1. jcwacky

    jcwacky Active Member

    Joined:
    Sep 4, 2002
    Messages:
    28
    Likes Received:
    2
    Trophy Points:
    153
    In cPanel > Optimize Website, I'm unable to enable the "Compress All Content" option.

    Upon selecting it, and clicking "Update Settings", it says it was successful: "Website optimization preferences updated. Content compression is now enabled. Content compression is now enabled for all content."

    But when I go back to the "Optimize Website" screen, it shows it's still disabled.
    • It happens on all cPanel accounts on the server.
    • I've reproduced the issue on a newly created cPanel account.
    • The "Compress the specified MIME types" won't enable either.
    • I've recently upgraded from EasyApache 3 to EasyApache 4.
    • I've tried uninstalling and re-installing the mod_deflate module via EasyApache 4.
    • It seems to successfully create a .htaccess file in the account root but doesn't add anything to it.
    • If I delete the .htaccess file and try again, it still just creates a new empty .htaccess file.
    • Some accounts already have it enabled, and the compression is working fine with these accounts.
    • WHM 62.0 (build 16) - 11.62.0.16
    • CLOUDLINUX 6.8 x86_64 kvm
    Any ideas how I can resolve this?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,367
    Likes Received:
    1,857
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. jcwacky

    jcwacky Active Member

    Joined:
    Sep 4, 2002
    Messages:
    28
    Likes Received:
    2
    Trophy Points:
    153
    Thanks, but I don't believe that's the same issue. For me, it won't insert the .htaccess content and despite saying it's enabled, when you go back, it says it's still disabled.

    I did try that PHP INI update, but it hasn't resolved this issue.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,367
    Likes Received:
    1,857
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Do you notice any error messages in /usr/local/cpanel/logs/error_log when attempting to enable the option?

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. jcwacky

    jcwacky Active Member

    Joined:
    Sep 4, 2002
    Messages:
    28
    Likes Received:
    2
    Trophy Points:
    153
    Nope, no errors appear in /usr/local/cpanel/logs/error_log, the only file that updates in that directory when attempting to enable Optimisation is access_log.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,367
    Likes Received:
    1,857
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    Could you open a support ticket using the link in my signature so we can take a closer look? You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. jcwacky

    jcwacky Active Member

    Joined:
    Sep 4, 2002
    Messages:
    28
    Likes Received:
    2
    Trophy Points:
    153
    I had buycpanel.com support get to the bottom of this. In case anyone else experiences the same issue, it seemed to be caused by file permissions of mod_pagespeed:
     
    cPanelMichael likes this.
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    44,367
    Likes Received:
    1,857
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Hello,

    I'm happy to see the issue is now resolved. Thank you for updating us with the outcome.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice