The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Optimize Website works only for main domain

Discussion in 'General Discussion' started by manima, Feb 2, 2011.

  1. manima

    manima Registered

    Joined:
    Feb 2, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Guatemala
    Hello, a newbie here asking for your help.

    I have two sites, the first is the main domain and the other is an addon domain. When I enable the Optimize Website option at CPanel only the main domain gets compressed. I tried to copy the htaccess file at root directory to the root of the addon domain but didn't work.

    The hosting company told me that they can help me if anything needs to be modified in the server side, but I have no idea what needs to be modified.

    In the addon domain I'm running a Wordpress blog with Hybrid News theme (a child theme of the Hybrid theme framework). Also when I enable the Hotlinking protection it breaks the theme, so I had to create a htaccess file at the Upload folder in the Wordpress directory because globally enabled, broke the theme. Hotlinking is working now for the addon domain (no issues here).

    Do you have any idea what's going on here?
    Any help will be appreciate, thanks in advance!

    CPanel ver. 11.28.64
    Apache ver. 2.2.17
    PHP ver. 5.2.16
    Perl ver. 5.8.8

    .htaccess file at home directory:
    <IfModule mod_deflate.c>
    SetOutputFilter DEFLATE
    <IfModule mod_setenvif.c>
    # Netscape 4.x has some problems...
    BrowserMatch ^Mozilla/4 gzip-only-text/html

    # Netscape 4.06-4.08 have some more problems
    BrowserMatch ^Mozilla/4\.0[678] no-gzip

    # MSIE masquerades as Netscape, but it is fine
    # BrowserMatch \bMSIE !no-gzip !gzip-only-text/html

    # NOTE: Due to a bug in mod_setenvif up to Apache 2.0.48
    # the above regex won't work. You can use the following
    # workaround to get the desired effect:
    BrowserMatch \bMSI[E] !no-gzip !gzip-only-text/html

    # Don't compress images
    SetEnvIfNoCase Request_URI .(?:gif|jpe?g|png)$ no-gzip dont-vary
    </IfModule>

    <IfModule mod_headers.c>
    # Make sure proxies don't deliver the wrong content
    Header append Vary User-Agent env=!dont-vary
    </IfModule>
    </IfModule>
     
  2. manima

    manima Registered

    Joined:
    Feb 2, 2011
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Guatemala
    Sorry to ask again!
    Any ideas what can be wrong?
     
Loading...

Share This Page