option '--sql_mode' requires an argument

grabyourhosting

Well-Known Member
Jan 18, 2007
92
6
158
cPanel Access Level
Root Administrator
Yes. It's
Code:
[mysqld]
log-error=/var/lib/mysql/you.yourdomain.com.err
performance-schema=on
innodb_file_per_table=1
local-infile=0
sql_mode=""
innodb_buffer_pool_size=128M
innodb_log_file_size=16M
open_files_limit=65536
max_allowed_packet=268435456
 

grabyourhosting

Well-Known Member
Jan 18, 2007
92
6
158
cPanel Access Level
Root Administrator
Same Issue. It takes forever to restart it just like before.
Here is the full error on the emails I am receiving.

Notification​
The service “mysql” appears to be down.​
Service Check Method​
The system’s command to check or to restart this service failed.​
Number of Restart Attempts​
614​
Service Check Raw Output​
(XID u8jh3f) The “mysql” service is down.

The subprocess “/usr/local/cpanel/scripts/restartsrv_mysql” reported error number 255 when it ended.​
Startup Log​
Aug 11 12:38:44 you.yourdomain.com systemd[1]: Starting MariaDB 10.3.23 database server...
Aug 11 12:38:48 you.yourdomain.com mysqld[1117]: 2020-08-11 12:38:48 0 [ERROR] /usr/sbin/mysqld: option '--sql_mode' requires an argument
Aug 11 12:38:49 you.yourdomain.com systemd[1]: mysql.service: main process exited, code=exited, status=1/FAILURE
Aug 11 12:38:49 you.yourdomain.com systemd[1]: Failed to start MariaDB 10.3.23 database server.
Aug 11 12:38:49 you.yourdomain.com systemd[1]: Unit mysql.service entered failed state.
Aug 11 12:38:49 you.yourdomain.com systemd[1]: mysql.service failed.​
Memory Information​
Used​
3.16 GB
Available​
8.08 GB
Installed​
11.24 GB
Load Information​
1.43 1.47 1.56
Uptime​
2 days, 3 hours, 51 minutes, and 37 seconds