The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Option Unkown Error with Entry in Exim Configuration Editor

Discussion in 'General Discussion' started by kirke, Dec 29, 2004.

  1. kirke

    kirke Registered

    Joined:
    Apr 26, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    When I try and use the Exim Configuration Editor to add an "interface =" line to the transports configuration section of the Exim confs, I get an 'option "interface" unknown' error:

    2004-12-29 10:19:02 Exim configuration error in line 950 of /etc/exim.conf.buildtest:
    option "interface" unknown
    Exim version 4.43 #1 built 06-Nov-2004 13:54:29
    Copyright (c) University of Cambridge 2004
    Berkeley DB: Sleepycat Software: Berkeley DB 4.0.14: (November 18, 2001)
    Support for: iconv() PAM Perl OpenSSL
    Lookups: lsearch wildlsearch nwildlsearch iplsearch dbm dbmnz
    Authenticators: cram_md5 plaintext spa
    Routers: accept dnslookup ipliteral manualroute queryprogram redirect
    Transports: appendfile autoreply pipe smtp
    Contains exiscan-acl patch revision 28 (c) Tom Kistner [http://duncanthrax.net/exiscan/]
    Configuration file has an invalid syntax. Please try again.

    I've tried using all three of the text boxes in that section with the same results. Adding the "interface =" option manually to the exim confs works fine but I dislike having to add the lines every time WHM overwrites the confs.

    Any ideas what could be going wrong?

    Thanks,

    Kirk
     
  2. dezignguy

    dezignguy Well-Known Member

    Joined:
    Sep 26, 2004
    Messages:
    534
    Likes Received:
    0
    Trophy Points:
    16
    perhaps you're adding it to the wrong section in whm...
    you can edit the whm files manually, you can kinda see where it puts each section. Your addition may need to be higher up in the conf file.

    What are you adding interfaces = for?
     
  3. kirke

    kirke Registered

    Joined:
    Apr 26, 2004
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    interface = x.x.x.x sets the machine ip that Exim binds to. It's supposed to go at the beginning of the transports section here:

    remote_smtp:
    driver = smtp
    interface = x.x.x.x

    Perhaps the fact that the Exim configuration editor doesn't place the entry exactly here is the problem? The entries are placed in the confs at the same location shown in the editor, which would either be right before these lines or much further down.

    Thanks for the suggestion but I'm nut sure how to address the problem.

    Kirk
     
Loading...

Share This Page