Bushman

Registered
Jun 21, 2008
4
0
51
OK, I know this question has been possed many times before but none of the solutions have worked for me.

A little history. I OSC based store front went down a few weeks back and it shows this error:

Server Requirement Error: register_globals is disabled in your PHP configuration. This can be enabled in your php.ini configuration file or in the .htaccess file in your catalog directory.

The rest of my site works fine (non os commerse bassed). I tried changing the htaccess and adding register_globals = 1 or on or what ever but then I just get a 500 error page.

Now, I'm pretty new at all this, so I need a step by step (babysteps) guide on how to fix this. If someone that can help me needs more info on my software versions or what ever, I'll try to answer them to the best of my abilities.
 

sparek-3

Well-Known Member
Aug 10, 2002
2,021
226
368
cPanel Access Level
Root Administrator
Are you using the latest version of OS Commerce? I thought the latest version of OS Commerce did not require register_globals.
 

Bushman

Registered
Jun 21, 2008
4
0
51
Well, I have OSC 2.2.... I know OSC 3.0 is out.... problem is that Cpanel will not let me upgrade... shows some warning about an upgrade test failed and that I assume all risk if it upgrade fails... kind of scary.

I guess since my store is not working... I should try it... whats the worst that can happen, my store doesnt work anyways.

Any other sugestions before I go with the upgrade? Has anyone been able to fix the 2.2 version?
 

InstaCarma_Tech

Well-Known Member
Apr 22, 2009
227
1
68
You can try putting the following line in the .htaccess file to enable register globals:

Code:
 php_flag register_globals on
If the above still generates the error then you can try creating a file named 'php.ini' in the folder named 'catalog' and put the following line in it :

Code:
 register_globals = on