elma

Member
Aug 13, 2003
15
0
151
I'm getting Out of memory! error when running easyapache from terminal or WHM.

Code:
Out of memory!
!! '/usr/local/cpanel/bin/userdata_update' failed with exit code '256' !!
cPanel support blamed the vps provider. The server is a Amazon EC2 instance (M3 Extra Large) with 15GB memory, utilizing just over 10% of it.


Code:
free -m
             total       used       free     shared    buffers     cached
Mem:         14882       2286      12595          0        188        781
-/+ buffers/cache:       1316      13565
Swap:            0          0          0

Linux --- 2.6.32-358.14.1.el6.x86_64 #1 SMP Tue Jul 16 23:51:20 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux
CENTOS 6.4 x86_64 xenpv – server  WHM 11.38.2 (build 3)
Any ideas?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Hello :)

Please check the following file:

Code:
/proc/user_beancounters
Do you notice any fail counts for the parameters in this file? If so, then your VPS is reaching limits imposed from the VPS hardware node.

Also, could you provide the ticket number of your support request with us?

Thank you.
 

elma

Member
Aug 13, 2003
15
0
151
Code:
[email protected] [~]# cat /proc/user_beancounters
cat: /proc/user_beancounters: No such file or directory
cPanel tickets ID# 4329555

I've tried a different instance, different availability zones, rolled back to previous kernel, tried forced upcp, restarted server.

Edit: Also created a swap file, didn't work.
 
Last edited:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
You can try increasing the following option under the "System" tab in "WHM Home » Server Configuration » Tweak Settings":

"Max cPanel process memory"

However, the "Out of memory!" message indicates your system is running out of memory. I see you are using the Xen environment, so the file I mentioned in my last response is not relevant in this case. Have you contacted your VPS hosting provider to have them check if there are any parameters configured on the VPS hardware node that could be restricting your memory usage?

Thank you.
 

elma

Member
Aug 13, 2003
15
0
151
You can try increasing the following option under the "System" tab in "WHM Home » Server Configuration » Tweak Settings":

"Max cPanel process memory"
Doubling the cPanel process memory has worked. easyapache has just completed, should I investigate further?

Code:
Updating your system to reflect any changes...
Updating Max cPanel process memory from “512” to “1024”.
Max cPanel process memory was updated.
Done.
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,202
363
Increasing the "Max cPanel process memory" value is a viable solution here. Further investigation should not be required unless you begin to experience memory issues again.

Thank you.