Outbound email issues for one domain

thowden

Well-Known Member
May 17, 2013
56
6
58
cPanel Access Level
Root Administrator
Hi all

I have two CPanel servers (well, 2 I am interested in today):
#1. Hosting server - at a host that blocks port 25 mail outbound.
#2. Hosting server - with a host that allows port 25 mail outbound

Server #1 uses -> Server #2 as a "smarthost"

#whmapi1 installed_versions packages=1|grep exim
#cpanel-exim: 4.94.2-4.cp1198
- cpanel-exim

Both servers consistent with exim (as above) and cpanel 98.0.8 versions. Differences? #1 is CentOS8.4 while #2 is CentOS7.8 - CloudLinux

Mail seems to flow for most / many of my hosted clients (sample testing shows no other unreasonable errors), so almost all good.

One specific domain sender gives me errors sending to an external client self-hosted server (SBS2011 - Exchange), but seems to send ok otherwise.

The specific messages bounce with failure message

"all hosts for 'externalserver.sbs2011.domain' have been failing for a long time (and retry time not reached)"

or

"retry timeout exceeded"

and initial defer messages

"Connection timed out H=my.server#2 [ip.address]: SMTP timeout after initial connection"

BUT....

if I send to that same external server from another account on Server#2, the email at externalserver.sbs2011.domain is processed / received ok.

Likewise if I manually utilise telnet to create an email at externalserver.sbs2011.domain it works fine.

I have been staring at this and testing as time permits for over week.

Its time to ask the audience for clues :)

Thanks in advance.

Tony
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,519
1,028
313
cPanel Access Level
Root Administrator
Hey there! It sounds like there is a cached failure for that domain in Exim. Can you try running these commands to clear the retry database to see if that gets things working?

Code:
/usr/sbin/exim_tidydb -t 0d /var/spool/exim retry > /dev/null
/usr/sbin/exim_tidydb -t 0d /var/spool/exim reject > /dev/null
/usr/sbin/exim_tidydb -t 0d /var/spool/exim wait-remote_smtp > /dev/null
 

thowden

Well-Known Member
May 17, 2013
56
6
58
cPanel Access Level
Root Administrator
Hi cPRex

I ran the three commands, without the dev/null just to see what was processed.

The first one cleared a heap of 'too old' entries.

The last one completed with:
# /usr/sbin/exim_tidydb -t 0d /var/spool/exim wait-remote_smtp
Tidying Exim hints database /var/spool/exim/db/wait-remote_smtp
Tidying complete

The middle one seems to want something different for its syntax:
# /usr/sbin/exim_tidydb -t 0d /var/spool/exim reject
Usage: exim_tidydb [-t <time>] <spool-directory> <database-name>
<database-name> = retry | misc | wait-<transport-name> | callout | ratelimit | tls

I'll go an test if that made any difference.

Thanks
Tony
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,519
1,028
313
cPanel Access Level
Root Administrator
I'm not really sure what could be causing that then - it would be best to have our team take a look directly at the server so we can see what's going on with that. If you're able to submit a ticket to our team, please post the number here so I can follow along and make sure this thread stays updated.