Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

outbound mail filter not working

Discussion in 'E-mail Discussions' started by SoftDux, Aug 20, 2017.

Tags:
  1. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    991
    Likes Received:
    2
    Trophy Points:
    168
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    Hi, I wonder if someone can help.

    Scenario: We use WHMCS and a client has requested not to receive certain emails. WHMCS nas no way to disable a specific email to a specific recipient. I can disable a specific email, for everyone though, but not for a single client.

    At the same time, certain senders who send proof of payments, send the proof of payment emails from a "noreply" email, resulting in the ticket reponse emails to always generate mail delivery reports.


    What I want to do:
    1) Filter outbound email from our WHMCS domain to this client (and other with the same request) blocking the emails he doesn't want to receive.

    2) Filter outbound emails to certain banks and other senders with a "noreply" email address.

    What I tried, without success:
    1) In cPanel > Email Filters > "Manage Filters" next to the support department email (same email that's setup in WHMS > Setup > General Settings > Email), I have added the following:
    • Filter Name: WHMCS
    • Rules: I selected "Subject" and "contains" in the 2 drop downs and typed in "filter test"
    • On the right I selected "and" on the drop down, and then + to add another rule
    • Then I selected "To" and "contains", and typed an email address (own of my own for this test).
    • On the "Actions" drop down I selected "Discard Message"
    • Then I Added a 2nd rule as above, named it "noreply" and added an email "noreply@mydomain (which I setup for this test.
    Then, in WHMC I sent an email to noreply@mydomain, and received it.

    I also sent an email to my email address with the subect "filter test" and received it.

    In both cases I shouldn't have received it, but did.


    how do I get these filters to work?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    38,165
    Likes Received:
    1,371
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
  3. SoftDux

    SoftDux Well-Known Member

    Joined:
    May 27, 2006
    Messages:
    991
    Likes Received:
    2
    Trophy Points:
    168
    Location:
    Johannesburg, South Africa
    cPanel Access Level:
    Root Administrator
    Thanx, I have submitted a feature request for this as I feel that doing it as root won't always help. The feature request can be found here: outgoing email filter for end users
     
    cPanelMichael likes this.
Loading...

Share This Page