SOLVED Outgoing and incoming Mail servers are domain.co.uk rather than mail.domain.co.uk

cPanel & WHM Version
96.0 (build 15)

hambees

Member
Aug 11, 2021
5
0
1
UK
cPanel Access Level
Root Administrator
So my mail server address is domain.co.uk for both incoming and outgoing for SSL but non SSL is mail.domain.co.uk how do i get it to be mail.domain.co.uk for SSL as well?
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,440
1,004
313
cPanel Access Level
Root Administrator
Hey there! It's important to note that the actual domain doesn't matter - as long as it points to your server, you'll be able to send email properly.

By default, cPanel creates the mail.domain.com subdomain when an account is created, so I would expect that to be included in the SSL certificate. Do you have DNS records for mail.yourdomain.co.uk configured to point to your server?
 

hambees

Member
Aug 11, 2021
5
0
1
UK
cPanel Access Level
Root Administrator
Hey so never had this problem before always been setup as Mail. Etc. I am using cloudflare which would have been pointing to mail. is there anyway for me to add it on or do I need to delete account and re-add? It’s causing me issue when trying to add to outlook or my phone.
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
7,440
1,004
313
cPanel Access Level
Root Administrator
Great - I'm glad that's all it ended up being.

In WHM >> Manage AutoSSL under the "Options" tab, there is the following option that could help you avoid this in the future, if you'd like to enable it:

"Allow AutoSSL to replace invalid or expiring non-AutoSSL certificates."