The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Outgoing mail as spam.. All domains..

Discussion in 'E-mail Discussions' started by Meinl, Jul 3, 2013.

  1. Meinl

    Meinl Member

    Joined:
    Jul 3, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi all,
    I don´t know what to do... i'm in the verge of dying...
    All my outgoing mail (for all my domains on my server) are delivered as SPAM.
    I've checked DKIM and SPF and both are enabled for all domains.
    I've checked DNSBL and i have no problem too.
    I've checked all exim config (it's all by default).
    Please, i need guidance to solve this problem, i really don't know what else to do..
    Thanks all, please help!
    Greets.
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    The solution for this issue depends on why the remote mail server is blocking email from your IP address. Is this happening on all remote email servers (E.g. Yahoo, GMail, Hotmail)? Or, do you only notice this on select remote servers?

    Have you checked to make sure RDNS is configured for your IP address so it points back to the hostname of your server?

    Thank you.
     
  3. Meinl

    Meinl Member

    Joined:
    Jul 3, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Yes, this is happening on all remote servers (Yahoo, Gmail and Hotmail).

    I've created my own DNS servers. For example, my hostname is srv1.example.cl, and my DNS are dns1.example.cl and dns2.example.cl (hostname and DNS servers are pointing to same IP address).

    There was a time that i was receiving severals mails with this subject:
    I fixed that. Yesterday, trying to fix this problem (SPAM), i set my RDNS again following cpanel manuals.

    Today i've received the same email from my server about DNS setup. I assumed that was about my RDNS setup, so i've deleted that config and let it by default.

    When i installed WHM first time, set my gmail account as admin email. All system mail were delivered to my spam folder (e.g when i created a package or modified an user account).

    I've read each thread about this problem and i can't solve.

    I don't know if i've overlooked some config, or if then install WHM at first time, default config should work without problems?.

    This could be a issue about my own DNS servers?.

    Please i need to solve this asap.

    Thanks all.

    Greets.
     
  4. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Typically, RDNS must be configured by your data center or hosting provider. It's not the same thing as an "A" record. It's a hostname associated with the IP address. You can check this with a command such as:

    Code:
    # host 1.2.3.4
    Replace "1.2.3.4" with the IP address used for sending email and ensure it outputs the hostname of your server.

    Thank you.
     
  5. Meinl

    Meinl Member

    Joined:
    Jul 3, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thank for your answer Michael,

    I put the following code on SSH "home" (#) and this was the server response:

    Code:
    Host XXX.XX.XX.XXX.in-addr.arpa. not found: 3(NXDOMAIN)
    That went using my ip (no the server IP).

    When i used the server ip i get this:

    Code:
    YY.YYY.YY.YYY.in-addr.arpa domain name pointer hostYY.YYY.YY.YYY.static.chilecom
    That's OK?

    Thank you again.

    I hope to solve this issue.

    Greets.
     
  6. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    It looks to be normal output, but it's difficult to confirm that because you are using examples instead of the actual hostname. Feel free to open a support ticket and we can check for common problems that may be causing this issue:

    Submit A Ticket

    You can post the ticket number here so we can update this thread with the outcome.

    Note that while we can not directly troubleshoot the fact that email from your server is detected as SPAM, we can rule out any common issues such as the lack of RDNS.

    Thank you.
     
  7. Meinl

    Meinl Member

    Joined:
    Jul 3, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thank you.

    The ticket ID is the following: 4286095

    Greetings.
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    I took a quick look at your ticket and noticed there is no RDNS record configured for the IP address associated with your server. Please contact your data center or hosting provider and have them setup RDNS for your IP address pointing back to the hostname of your server.

    Thank you.
     
  9. Meinl

    Meinl Member

    Joined:
    Jul 3, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Michael,

    How can you see that through WHM?. I used this site: Reverse Lookup - MxToolbox to check my RSDN (with IP server) and i get a success answer with a RDNS asociated to my server IP.

    So, the hostname always had an associated reverse dns.

    Thanks again.
     
  10. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Per the ticket, your hostname resolves to an IP address, but the IP address does not have a PTR record (RDNS) configured back to the hostname. This should be added by your data center or hosting provider.

    If you prefer a third-party resource as opposed to the command line to check for RDNS, you can enter your IP address on a website such as:

    CentralOps

    You will notice a result such as:

    Thank you.
     
  11. Meinl

    Meinl Member

    Joined:
    Jul 3, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Michael,

    I'm clear now. some posibility to see that info inside WHM or command line?.

    Can i add the RDNS by myself? maybe in WHM? or this can be solve only for my DC?

    Thank's for all.

    Greets.
     
  12. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You will need to contact your hosting provider or data center to have them configure your PTR record (RDNS) for you. Provide them with your IP address and let them know you want the RDNS pointed back to your server's hostname. You can verify the record after they add it and it propagates with the "host" command mentioned in my previous post in this thread.

    Thank you.
     
  13. Meinl

    Meinl Member

    Joined:
    Jul 3, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Michael,

    They asked me the name of PTR i want to set.

    Which is suppose to be?

    I really appreciated.

    Greets.
     
  14. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    It should be for the hostname of your server. This is the same hostname you have configured in:

    "WHM Home » Networking Setup » Change Hostname"

    Thank you.
     
  15. Meinl

    Meinl Member

    Joined:
    Jul 3, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Ok, that's the deal.

    They already configured the RDNS. Now is pointing to my hostname.

    When i run
    Code:
    # dig -x [I]IP_OF_MY_SERVER[/I]
    sometimes i get my hostname, and sometimes the past (wrong) hostname

    They could be set 2 PTR's?, If that is possible, that's wrong, right?.

    When i run
    Code:
    # host [I]IP_OF_MY_SERVER[/I]
    , that always pointing to my hostname.

    They add the PTR recent, i have to wait a long time?

    Otherwise, i was looking in WHM - Networking Setup - Resolver Configuration, i have the default IP's. I have to change it for server IP?.

    Thank you.
     
  16. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,762
    Likes Received:
    662
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    The PTR record (RDNS) is working properly for your server's IP address from my location. It will likely take some time before it propagates throughout the Internet. You should not change your DNS resolvers to your server IP address. It's a good idea to leave those set to what they are already configured as.

    Thank you.
     
  17. Meinl

    Meinl Member

    Joined:
    Jul 3, 2013
    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Finally works!

    The mail is delievered to inbox folder at last.

    Thank you for all your help.

    I will post the solution if someone else could have the same problem.

    1.- Check SPF and DKIM both must be enabled. (WHM -> Tweak settings -> Domains tab)
    2.- Check DNS blacklist. (check this site: http://mxtoolbox.com/blacklists.aspx)
    3.- Check if your hostname resolves a valid (and correct) IP address. You can use this code under command line:
    Code:
    # host [I]server_ip[/I]
    The response must be your hostname.

    4.- Check PTR records or RDNS, it must be resolved a valid hostname (your hostname) you can this code:
    Code:
    # dig -x [I]server_ip[/I]
    The response must be your reverse IP pointing to the hostname (your hostname) like next example:

    Code:
    XX.XXX.XX.XXX.in-addr.arpa. 14400 IN    PTR     [I]your_hostname.[/I]
    * If you prefer a third-party resource instead command line, you can enter your server_ip at following site: http://centralops.net/co/

    5.- Check DNS records and Hostname, both must be pointing to your IP address.

    That's it. If someone needs help, i'm able to help.

    Greets and thank you again for all your help Michael.

    See ya!
     
    #17 Meinl, Jul 5, 2013
    Last edited: Jul 5, 2013
Loading...

Share This Page