The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Outgoing mail not authenticating?

Discussion in 'E-mail Discussions' started by noimad1, Sep 11, 2005.

Thread Status:
Not open for further replies.
  1. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    One of my servers all of a sudden, no one can send outgoing mail. It just gives them an authentication error, or keeps poping up the password dialog box.

    I set up my own test account there, and the same thing is happening for me as well.

    This is happening on all domains on the server.

    version WHM 10.6.0 cPanel 10.6.0-C197

    I have tried the following:

    /scripts/mailperm
    /scripts/updateuserdomains

    still no luck...


    Here is something I've found out....if I uncheck the "my server requires authentication" the mail goes through no problem. We've for years had the users check that box, and now all of a sudden it doesn't work? So what could the problem be?

    I can't have all of the users on this system go back and change that setting now....
     
    #1 noimad1, Sep 11, 2005
    Last edited: Sep 11, 2005
  2. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16

    I was searching bugzilla and found this:

    http://bugzilla.cpanel.net/show_bug.cgi?id=3146

    It looks like the files in /var/cpanel/users/ need to be set to 644 in order for the authenticaiton to work....I tested it and it worked...
     
  3. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    My Current has not updated yet and the mode was 640 - not 644. No sense in giving too much permission.
     
  4. noimad1

    noimad1 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    627
    Likes Received:
    0
    Trophy Points:
    16
    I was thinking the same thing, but set at 600 on this particular server and the authentication would not work. I changed them to 644 and they started working right away. So that was the only solution I could find...
     
  5. lloyd_tennison

    lloyd_tennison Well-Known Member

    Joined:
    Mar 12, 2004
    Messages:
    698
    Likes Received:
    1
    Trophy Points:
    18
    or 640? You say 600...
     
  6. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    Indeed, they should be set to 640 as I explained in your cross-post (and closing this thread in favour of it, please don't cross-post).
     
Loading...
Thread Status:
Not open for further replies.

Share This Page