The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Outlook auto config

Discussion in 'General Discussion' started by NeoPuma, Jun 18, 2005.

  1. NeoPuma

    NeoPuma Member

    Joined:
    Jun 18, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hey there,
    I am a reseller and i use CPanel for the control panel. One of my customers have just told me that if you click on Outlook auto config, you get all the popup boxes, and then it loads up the .reg file in firefox, as a text file. All you can see is the information in it, and not performing it. Could you please make a fix to make it 'Firefox friendly' please, or is there a way to fix this?

    Thanks
     
  2. ccccanada

    ccccanada Well-Known Member

    Joined:
    Jan 17, 2003
    Messages:
    279
    Likes Received:
    0
    Trophy Points:
    16
    Its Outlook Express and not Outlook that gets set up and it only works with IE and no other browser.
     
  3. NeoPuma

    NeoPuma Member

    Joined:
    Jun 18, 2005
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    At least figure out what brower they use, and if its IE, keep it there, or if its different, remove it? It aint too hard if you know how.
     
  4. truehustercom

    truehustercom Member

    Joined:
    Aug 27, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    the same thing happens in IE with me.
     
  5. Stu

    Stu Registered

    Joined:
    Feb 8, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Our customers are now experiencing this in IE and Firefox
     
  6. brianoz

    brianoz Well-Known Member

    Joined:
    Mar 13, 2004
    Messages:
    1,146
    Likes Received:
    6
    Trophy Points:
    38
    Location:
    Melbourne, Australia
    cPanel Access Level:
    Root Administrator
    Save it as a file with a .reg extension and execute (double-click) it from Windows explorer.

    One fix is for CPanel to make the mime type a registry mime type, if they aren't already. Or, if they are, detect that it's not IE and make it an unknown registry type which will force it to be saved.

    In PHP, this looks like this (a subset of this will work too):

    PHP:
    header('Content-type: application/force-download');
    header('Content-Disposition: attachment; filename="'.
        
    trim(htmlentities($file)).'"');
    header("Content-Length: ".(string)(filesize($full)));
    header("Cache-control: private");
    header("Content-Description: ".trim(htmlentities($file)));
    header("Connection: close");
    Outlook will pick up the changes to the registry, at least it did in Outlook 2002, and adopt the new Outlook Express account, so unless things have changed it used to work in both Outlook and Outlook Express.
     
  7. networxhosting

    networxhosting Well-Known Member
    PartnerNOC

    Joined:
    Apr 22, 2003
    Messages:
    80
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Hamilton, Ontario, CANADA
    This is also happening to me on all of our servers (centos 3, cPanel CURRENT build)

    Outlook autoconfig just spits the reg file's text into the browser, and does NOT prompt to save the reg file like it used to.

    Has anyone submitted a bugzilla request? If so, please post in here and i will add comments/vote as well
     
  8. truehustercom

    truehustercom Member

    Joined:
    Aug 27, 2004
    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    I tried this and got the following error The specified file is not a registry script.
    You can only import bianary registry files from within the registry editor.



    has anyone figured out how to fix this?
     
  9. jackal

    jackal Well-Known Member
    PartnerNOC

    Joined:
    Feb 23, 2002
    Messages:
    708
    Likes Received:
    0
    Trophy Points:
    16
    Does this in IE also
     
  10. jhobbs

    jhobbs Member

    Joined:
    Feb 3, 2003
    Messages:
    24
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Sturgis, Michigan
    Does this (displays in browser, doesn't save to file) on both FireFox and IE6 on my system.
    Windows XP Pro, current versions of FireFox and IE6.
    cPanel 10.4.0-C160

    .REG file type is set to open in Registry Editor.
    Tried saving the text in IE to .REG and used and editor to save the text (copied from the clipboard) in several different formats, no help.

    Any ideas?

    Jack.
     
    #10 jhobbs, Jul 29, 2005
    Last edited: Jul 29, 2005
  11. cPanelKyle

    cPanelKyle Technicial Analyst III/Migrations Specialist
    Staff Member

    Joined:
    Feb 10, 2003
    Messages:
    58
    Likes Received:
    0
    Trophy Points:
    6
    cPanel Access Level:
    Root Administrator
    Twitter:
  12. WebTrooper

    WebTrooper Member

    Joined:
    Nov 7, 2004
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    Myabe I'm missing something, bugzilla is no help at all. It shows the .reg file as displayed in the browser and a few comments saying basically "Yep, same here." It's says "Resolved" which is nice, but I can't find the resolution. What should I be looking for? :confused:
     
  13. Stu

    Stu Registered

    Joined:
    Feb 8, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Same here...

    How is this fixed ?
     
  14. WebTrooper

    WebTrooper Member

    Joined:
    Nov 7, 2004
    Messages:
    22
    Likes Received:
    0
    Trophy Points:
    1
    This is a serious issue and needs fixed.
     
  15. adept2003

    adept2003 Well-Known Member

    Joined:
    Aug 11, 2003
    Messages:
    283
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    ~ "/(extra|special)/data"
    This is a temporary fix:

    1. #pico /usr/local/apache/conf/mime.types
    2. Scroll down to the line:
    Code:
    application/octet-stream	bin dms lha lzh exe class so dll dmg
    3. Add "reg" to the end of the line (without quotes!)
    4. Save changes & restart Apache.

    Regards,
     
  16. adept2003

    adept2003 Well-Known Member

    Joined:
    Aug 11, 2003
    Messages:
    283
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    ~ "/(extra|special)/data"
    Oh, and if the above doesn't fix it, then undo the changes above and add the following line to mime.types:
    Code:
    application/x-msdownload		reg
    If the line already exists, then just append "reg" to the end of it.
    Then save changes & restart apache.
     
  17. ctbhost

    ctbhost Well-Known Member

    Joined:
    May 31, 2002
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    16
    tried both the above and still no change
     
  18. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    What version of cpanel are you using ?
     
  19. ctbhost

    ctbhost Well-Known Member

    Joined:
    May 31, 2002
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    16
    WHM 10.6.0
    Cpanel 10.6.0-R55

    Fedora i686
     
  20. ctbhost

    ctbhost Well-Known Member

    Joined:
    May 31, 2002
    Messages:
    139
    Likes Received:
    0
    Trophy Points:
    16
    any Fix for thsi yet ????
     
Loading...

Share This Page