Outlook Error: Your server does not support the connection encryption type you have specified

Operating System & Version
centos 7.9
cPanel & WHM Version
v94.0.4

mmaciel

Active Member
Mar 25, 2019
31
4
8
Brazil
cPanel Access Level
Root Administrator
Hey everyone. So recently i've migrated servers, from centos 6.10 v86.0.38 to centos 7.9 v94.0.4, and after the transfer some of our users utilizing outlook 2016 on windows 7 machines started getting this error.

I've read and tried every method mentioned here, here and here, but nothing seem to work, i still can't log in with an account using encrypted pop3 connection. It actually fails to login when outlook is trying to test the account configurations, via that initial setup.

Any idea to what else could i change so it work? It worked on my old server and i actually tried to copy some of the security settings from exim and mailserver configuration in whm to the new one, and now i can successfully login utilizing port 110, but other than that, nothing works.
 
Last edited by a moderator:

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,938
609
273
cPanel Access Level
Root Administrator
Hey there! Can you try the details listed here:


Ideally, those users should consider updating the Windows 7 systems as many things are out of date already, with only more to come.
 

mmaciel

Active Member
Mar 25, 2019
31
4
8
Brazil
cPanel Access Level
Root Administrator
Hey there! Can you try the details listed here:


Ideally, those users should consider updating the Windows 7 systems as many things are out of date already, with only more to come.
hey man, thanks for link

i had already tried patching windows and adding those registry entries, but nothing really changed, and now after following the non recommended option 2, things actually got worse hehe, i can't login anymore even without encryption with port 110 (it worked before)

after messing with the setting in the exim configuration, it appears that the option Require clients to connect with SSL or issue the STARTTLS command before they are allowed to authenticate with the server set to ON is what is blocking my access (i can login using port 110/587 when this option is OFF), but other than that, changing the other options mentioned in the article you linked does nothing and i still can't make it work with encryption on (port 995) no matter what

do you have any other idea to what could be happening ?
 

mmaciel

Active Member
Mar 25, 2019
31
4
8
Brazil
cPanel Access Level
Root Administrator
Did you try the things in option 2? It's also worth noting that you can take a backup and reset the Exim configuration back to the cPanel defaults through the WHM interface.
i did, and like i said, it made things worse, still wouldn't login using encrypted options with port 995 and wouldn't be able to receive/send mails even without using encrypted connection with port 110

i actually wrote down the default settings before changing anything
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
4,938
609
273
cPanel Access Level
Root Administrator
I'm sorry to hear that caused further issues. We've been providing that guide to Windows 7 users for many years, so if that isn't working I'm not sure what the issue may be. You're always welcome to submit a ticket to our team so we can check the server settings on our end directly.
 

mmaciel

Active Member
Mar 25, 2019
31
4
8
Brazil
cPanel Access Level
Root Administrator
I'm sorry to hear that caused further issues. We've been providing that guide to Windows 7 users for many years, so if that isn't working I'm not sure what the issue may be. You're always welcome to submit a ticket to our team so we can check the server settings on our end directly.
thanks, i will do that then
 
  • Like
Reactions: cPRex

mmaciel

Active Member
Mar 25, 2019
31
4
8
Brazil
cPanel Access Level
Root Administrator
Hey, just to update here, my problem was solved after opening the ticket. Cpanel team sent me this link and recommended me to try it instead of enabling SSLv2 and SSLv3, which they strongly disencouraged. I did what the article said and everything started working again.

I just want to point out that i had already tried the method suggested by that article before opening the ticket, in fact, i followed the instructions from this article by cpanel themselves. The online thing i changed was instead of creating QWORD values like cpanel article indicates for 64-bit systems, which we are using, i simply used DWORD values for the registry entries and after that everything worked.
 
  • Like
Reactions: cPRex