OVH Server stuck at Grub prompt when booted to HDD


Active Member
May 10, 2018
cPanel Access Level
Root Administrator
I realize this isnt a WHM/Cpanel issue but hopefully this wonderful community can help. Today we had a hardware failure (motherboard) and after it was replaced the server was booted up by the techs at OVH. However, it was getting stuck at a Grub prompt screen. Unfortunately, OVH said we are on our own as they dont have software support. This actually happened last year at one point when we rebooted our server after a WHM update. At that time we just followed the instructions found here: GitHub - JustOneMoreBlock/ovh-grub-error

That fixed it quite fast and easily. The big difference was last year OVH had their own kernel network mode that allowed us to get booted up and then make the configuration in that link to create a new grub.cfg file.

However, this year we have found that this network mode kernel is no longer available and since the HDD method gets stuck at the Grub prompt, we are left with a Debian Rescue boot mode option.

Now those commands no longer work. Have hired 2 admins but they havent been able to figure it out. We have tried all sorts of fixes and not getting anywhere.

We dont want to go to the last resort which is to back up, reformat the server and restore through Cpanel back up.

Hoping someone here can help with this issue. Server has already been down for over 15 hours and still can't figure this out. It really should be an easy fix but there nothing online that talks about getting this issue fixed via rescue mode. Thanks in advance if you can assist.



Well-Known Member
Jun 9, 2020
cPanel Access Level
Root Administrator
Well it's a bit hard to say what exactly you need to do as every system is different but basically:

1. Boot it into rescue
2. Mount the partitions to their respective folders (/mnt/boot, /mnt/home etc..) myLoc managed IT AG - FAQ - How do I mount disks in rescue mode?
3. Double check your fstab file with your boot partition partition (cat /mnt/etc/fstab)
4. Reinstall grub on that partition (grub2-install /dev/XXX)
5. Try to restart server and see if that worked.

Again this is just a genetal guidance but hopefully helps...