Oxwall on cPanel issue (SyntaxError)

Zadakine

Registered
Mar 16, 2017
2
0
1
The Netherlands
cPanel Access Level
Website Owner
Hi there, I'm new to this forum.

I'm using Oxwall (social network software) on cPanel for a few days now and yesterday some functions stopped working. People can't change their avatar, drop down menu is not popping up if the cursor is over the user icon. I can't select/activate a new theme or save custom CSS in the Admin Panel of Oxwall (nothing happens when I click on the buttons). Also tabs on profile pages and some buttons are not working (simply nothing happens).

Since I'm new to coding I don't know what to do. If I inspect my site with Google Chrome it gives me errors like:

On my profile: SyntaxError: Invalid or unexpected token /user/Zadakine:2269
On my Admin Panel (Oxwall): SyntaxError: Invalid or unexpected token /admin:1780

How do I get rid of this error? Where do I have to look in cPanel to solve this?
 

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,910
2,213
363
Hello,

That looks like an issue with the script itself. You may want to reach out to the support team for the software you are using, or contact your web hosting provider to see if they can review logs on the server for anything that might be causing the error messages.

Thank you.
 

Zadakine

Registered
Mar 16, 2017
2
0
1
The Netherlands
cPanel Access Level
Website Owner
Thanks for the fast answer. I already contacted my hosting provider. They couldn't do anything. Oxwall not responding thus far. But I found an error.log file. Could that be it?

This is the error:
Code:
[Sat Mar 11 10:16:00 2017] [ow_core_log] [Notice] Message: Undefined index: HTTP_USER_AGENT File: /home/animalcr/public_html/ow_core/request.php Line:137
This is at the line 137:
PHP:
        return UTIL_Browser::getBrowser($_SERVER['HTTP_USER_AGENT']);
So what's wrong in the code?