Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Page has Expired on a CGI when clicking BACK.

Discussion in 'General Discussion' started by mpierre, Oct 7, 2003.

  1. mpierre

    mpierre Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    166
    I have a client that just switched to us, and they have a cgi script that they use the back button often on.

    Everytime they click back, they get :

    Warning :Page has Expired

    on IE, but it works on other browsers...

    I tested on the old server ( apache, not Cpanel ), and it works on IE.

    I tested on other CGI scripts, and they ALL do that on my server ( I only use PHP scripts ).

    Is there ANYTHING I can do short of changing the CGI scripts ?

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. mjm2

    mjm2 Well-Known Member

    Joined:
    Oct 3, 2003
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    156
    Location:
    rm -rf /
    cpanel is not a webserver. it is simply management software.

    your machine most likely is using apache as an HTTP server.

    cPanel.net Support Ticket Number:
     
  3. mpierre

    mpierre Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    166
    D'oh.... I am fully aware of that !

    When I said "Apache not Cpanel" I meant of course :

    "They are running Apache ( like I am ) but not CPanel".

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. mpierre

    mpierre Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    166
    I have tried setting this option :

    #
    # CacheNegotiatedDocs: By default, Apache sends "Pragma: no-cache" with each
    # document that was negotiated on the basis of content. This asks proxy
    # servers not to cache the document. Uncommenting the following line disables
    # this behavior, and proxies will be allowed to cache the documents.
    #
    CacheNegotiatedDocs

    But it still doesn't work.

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. mpierre

    mpierre Well-Known Member

    Joined:
    Jun 30, 2002
    Messages:
    196
    Likes Received:
    0
    Trophy Points:
    166
    Until I find a better solution, I am using get instead of post, but nice a password is passed, it is not a great solution...

    Anyone knows an options that can be changed in httpd.conf to fix the IE problem ?

    cPanel.net Support Ticket Number:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice