The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Parked domain changes address bar on installed apps

Discussion in 'General Discussion' started by tulsabobt, Oct 25, 2007.

  1. tulsabobt

    tulsabobt Active Member

    Joined:
    Aug 9, 2004
    Messages:
    28
    Likes Received:
    0
    Trophy Points:
    6
    Hello,

    I have a domain that was developed, say rootdomain.com and now that is open we have taken the advertised/promoted domain and parked it on top. So domain1.com is now parked on rootdomain.com.

    This client has gone to Netsol and pointed ONLY there www to the new rootdomain.com static i.p. as well, since they maintain their own e-mail server.

    All works well, except when you click on a blog or a gallery installed by Fantastico or Cpanel scripts. Then it reverts 9in the address bar) back to the rootdomain.com. It still works, but the client wants the consistent URL.

    I have other sites with identical setups that work fine, so I'm unsure of the problem. I know for certain Gallery does not use a domain name in any of it's operations so this is definitely a server/dns issue.

    Anyeone happen to know what I am missing?

    Thanks,
    BT
     
  2. cPanelDavidG

    cPanelDavidG Technical Product Specialist

    Joined:
    Nov 29, 2006
    Messages:
    11,279
    Likes Received:
    8
    Trophy Points:
    38
    Location:
    Houston, TX
    cPanel Access Level:
    Root Administrator
    Many PHP scripts include a $base_url (or similar) variable in their configuration files. If this is configured for rootdomain.com rather than domain1.com, that would explain the inconsistency.
     
Loading...

Share This Page