The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Parked Domain / Redirect not working

Discussion in 'General Discussion' started by Hedloff, Dec 16, 2010.

  1. Hedloff

    Hedloff Well-Known Member

    Joined:
    Jun 7, 2004
    Messages:
    98
    Likes Received:
    2
    Trophy Points:
    8
    After update to 11.28.45 we have a lot of problems with different sorts and this problem is with parked domains and url forwarding/redirect in cpanel.

    Say we have domain.com as main domain, and domain2.com as parked domain on top of 2.domain.com subdomain, but when we want domain2.com redirected to somewhere else in cpanel to domain.com/help/doc/ f.eks it does not work.
    The redirect is showing in cpanel, but the .htaccess file is always made in the public_html folder and not in public_html/2/ folder as it should.

    WHY is this and will it get fixed?
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    I'm sorry, I'm not clear on your post to test this for you. This part for starters:

    Where did 2.domain.com come in? Is this a typo?

    And this part:
    What is f.eks? A file, a typo here?

    And this:
    I take it the redirect does not work, is that right? You mention it's not where you want it, but not if it works or not, exactly. Assuming by thread title, no.
     
  3. Hedloff

    Hedloff Well-Known Member

    Joined:
    Jun 7, 2004
    Messages:
    98
    Likes Received:
    2
    Trophy Points:
    8
    Correct. Redirect does not work because cPanel place the .htaccess file with the redirect in the public_html folder, when it should be placed in the subdomain folder where the addon domain is parked so the redirect to for example domain.com/help/doc/ does not work.
     
  4. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Your not adding this via the Redirects section of your cPanel, or are you?

    If I understand you correctly, when I try to duplicate via Redirects section, I get this message:

    Please provide exact steps to get there, please.
     
  5. Hedloff

    Hedloff Well-Known Member

    Joined:
    Jun 7, 2004
    Messages:
    98
    Likes Received:
    2
    Trophy Points:
    8
    Yes, in cPanel and redirects customers are trying to add a url redirect to for example cnn.com, but the .htaccess file that are made is being placed in the wrong directory.
    It always is placed in public_html folder, and not the subdomain folder where the addon/parked domain is, so the redirect is not working.

    This problem occured after cPanel update...
     
    #5 Hedloff, Dec 17, 2010
    Last edited: Dec 17, 2010
  6. Hedloff

    Hedloff Well-Known Member

    Joined:
    Jun 7, 2004
    Messages:
    98
    Likes Received:
    2
    Trophy Points:
    8
    The problem still exist on our servers and does not work at all. Does anyone have any fix on this problem?
     
  7. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,447
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Can you please provide the steps to duplicate the issue?
     
  8. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Helo Hedloff,

    We did have an issue with addon domain redirects not saving to the correct .htaccess file per case #44627, which was fixed in 11.28.48. What is your current cPanel version?

    Code:
    cat /usr/local/cpanel/version
    Thanks.
     
  9. MattDr2

    MattDr2 Well-Known Member
    PartnerNOC

    Joined:
    Feb 19, 2003
    Messages:
    84
    Likes Received:
    0
    Trophy Points:
    6
    Location:
    Norman, OK
    We are seeing this issue on a freshly updated system, as well. Running 11.28.64 Stable release.
    Edit: running 11.28.64 Stable*
     
    #9 MattDr2, Feb 2, 2011
    Last edited: Feb 2, 2011
  10. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please open a ticket with us using WHM > Support Center > Contact cPanel for us to check into this further. Please ensure to provide specific details in the ticket for the account and domain where this is happening.
     
  11. luigidelgado

    luigidelgado Well-Known Member

    Joined:
    Nov 6, 2010
    Messages:
    109
    Likes Received:
    2
    Trophy Points:
    16
    Location:
    Mexico
    cPanel Access Level:
    Root Administrator
    Twitter:
    Im having a similar problem here.

    Im trying to set up an EZ Publish 4.4 "hostname" install which requires to have www.mydomain.com and admin.mydomain.com set.

    I tryed both, making a subdomain and a parked domain (complete admin.mydomain.com parking). I even got into WHM to enable the "allow host subdomains to be parked" no luck. No errors when adding, they just go nowhere (NOT FOUND).

    I could only make this work for one time, the first time I added it as parked domain. I'vee been trying to make it work for tenths of times unsuccessfully. Checked everything, DNS zones, httpd.conf, htaccess, and everything seems alright.

    cPanel 11.28.83
     
  12. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Did you manage to open up a ticket for this issue, Luis, for us to check into it as suggested? If so, please let us know the ticket number. If not, it only takes a few moments to open up one using either the link in my signature or WHM > Support Center > Contact cPanel. If there's some general issue with redirects happening, we would want to investigate it via the support desk.
     
  13. Hedloff

    Hedloff Well-Known Member

    Joined:
    Jun 7, 2004
    Messages:
    98
    Likes Received:
    2
    Trophy Points:
    8
  14. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    Please open up a ticket.
     
Loading...

Share This Page