The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Part of backups not deleted after being moved to another destination

Discussion in 'Data Protection' started by privard, Feb 4, 2014.

  1. privard

    privard Member

    Aug 10, 2013
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator
    Hello all :)

    cPanel version I am using on 2 different servers:
    WHM 11.42.0 (build 4)
    WHM 11.40.1 (build 10)

    Both reproduce the same problem (or feature?). I have the new backup system enabled (old one disabled). I backup system files as well as all accounts, sql, etc. on each server. The "Retain backups in the default backup directory." toggle is unticked. Everything (or so I thought) is moved to another FTP destination.

    So when I look at the backup folder on each server, all accounts have been moved to the remote FTP destination and deleted from the server - this part works as intended. But all system files are still on the server and not even copied to the remote server... is this a bug or a feature?

    If it's a feature, how can we change the behavior of the backup to send system files to the remote server as well and then delete them locally?
  2. cPanelPeter

    cPanelPeter Technical Analyst III
    Staff Member

    Sep 23, 2013
    Likes Received:
    Trophy Points:
    cPanel Access Level:
    Root Administrator

    System backups are not transferred to a remote server by design. Some of the files in system backup contain passwords, so it is disable by default to transfer the system backups to a remote server. This way if the remote FTP server ever gets compromised, hackers will not be able to steal the data and use it against your customers.

    If you insist on having the backup system store system files on the remote server, you would need to manually modify
    the config file.

    Documentation on how to do that is here.

Share This Page