Passenger won't appear even after correct installation

Operating System & Version
CentOS v7.9.2009
cPanel & WHM Version
v100.0.12

snb74883

Registered
Apr 21, 2022
2
0
1
Malaysia
cPanel Access Level
Root Administrator
OS: CentOS v7.9.2009
cPanel Version: v100.0.12
This is a brand new VPS I just ordered with 0 settings made on the WHM/cPanel besides from editing the DNS zones and uploading a static `index.html` file under "public_html".


I have an Account that uses the feature package "default".
Under Feature Manager, "default" has Application Manager checked.

I installed the following via WHM > EasyApache 4
  • mod_env
  • ruby27-mod_passenger
However after a successful installation, my cPanel still doesn't have Passenger / Application Manager visible.

Things I tried:
Restarting Apache
Bruteforcing my way into the Application Manager page
By navigating to "/frontend/jupiter/passenger/index.html" on the browser however was met with the error:​
You do not have the feature “passengerapps”.
Waiting a few hours

To no avail, I decided to post a thread here to seek help.

Listed below is the list of packages installed on my EasyApache 4:

Code:
Apache 2.4
[LIST]
[*]config
[*]config-runtime
[*]mod_bwlimited
[*]mod_cgi
[*]mod_deflate
[*]mod_env
[*]mod_expires
[*]mod_headers
[*]mod_mpm_prefork
[*]mod_proxy
[*]mod_proxy_fcgi
[*]mod_proxy_http
[*]mod_proxy_wstunnel
[*]mod_ruid2
[*]mod_security2
[*]mod_ssl
[*]mod_unique_id
[*]tools
[/LIST]
PHP 7.4
[LIST]
[*]libc-client
[*]pear
[*]php-bcmath
[*]php-calendar
[*]php-cli
[*]php-common
[*]php-curl
[*]php-devel
[*]php-fpm
[*]php-ftp
[*]php-gd
[*]php-iconv
[*]php-imap
[*]php-litespeed
[*]php-mbstring
[*]php-mysqlnd
[*]php-pdo
[*]php-posix
[*]php-sockets
[*]php-xml
[*]php-zip
[*]runtime
[/LIST]
PHP 8.0
[LIST]
[*]libc-client
[*]pear
[*]php-bcmath
[*]php-calendar
[*]php-cli
[*]php-common
[*]php-curl
[*]php-devel
[*]php-fpm
[*]php-ftp
[*]php-gd
[*]php-iconv
[*]php-imap
[*]php-litespeed
[*]php-mbstring
[*]php-mysqlnd
[*]php-pdo
[*]php-posix
[*]php-sockets
[*]php-xml
[*]php-zip
[*]runtime
[/LIST]
Additional Packages
[LIST]
[*]apr
[*]apr-util
[*]brotli
[*]cpanel-tools
[*]documentroot
[*]libargon2
[*]libcurl
[*]libnghttp2
[*]libxml2
[*]libzip
[*]modsec-sdbm-util
[*]nghttp2
[*]oniguruma
[*]oniguruma-devel
[*]openssl
[*]openssl11
[*]php-cli
[*]php-cli-lsphp
[*]profiles-cpanel
[*]ruby24-ruby
[*]ruby24-ruby-irb
[*]ruby24-ruby-libs
[*]ruby24-rubygem-bigdecimal
[*]ruby24-rubygem-did_you_mean
[*]ruby24-rubygem-io-console
[*]ruby24-rubygem-json
[*]ruby24-rubygem-openssl
[*]ruby24-rubygem-psych
[*]ruby24-rubygem-rdoc
[*]ruby24-rubygems
[*]ruby24-runtime
[*]ruby27-libuv
[*]ruby27-mod_passenger
[*]ruby27-ruby
[*]ruby27-ruby-devel
[*]ruby27-ruby-irb
[*]ruby27-ruby-libs
[*]ruby27-ruby-wrapper
[*]ruby27-rubygem-bigdecimal
[*]ruby27-rubygem-did_you_mean
[*]ruby27-rubygem-io-console
[*]ruby27-rubygem-json
[*]ruby27-rubygem-openssl
[*]ruby27-rubygem-passenger
[*]ruby27-rubygem-psych
[*]ruby27-rubygem-rack
[*]ruby27-rubygem-rdoc
[*]ruby27-rubygems
[*]ruby27-runtime
[/LIST]
 
Last edited by a moderator:

Spirogg

Well-Known Member
Feb 21, 2018
700
160
43
chicago
cPanel Access Level
Root Administrator
OS: CentOS v7.9.2009
cPanel Version: v100.0.12
This is a brand new VPS I just ordered with 0 settings made on the WHM/cPanel besides from editing the DNS zones and uploading a static `index.html` file under "public_html".


I have an Account that uses the feature package "default".
Under Feature Manager, "default" has Application Manager checked.

I installed the following via WHM > EasyApache 4
  • mod_env
  • ruby27-mod_passenger
However after a successful installation, my cPanel still doesn't have Passenger / Application Manager visible.

Things I tried:
Restarting Apache
Bruteforcing my way into the Application Manager page
By navigating to "/frontend/jupiter/passenger/index.html" on the browser however was met with the error:​
You do not have the feature “passengerapps”.
Waiting a few hours

To no avail, I decided to post a thread here to seek help.

Listed below is the list of packages installed on my EasyApache 4:

Code:
Apache 2.4
[LIST]
[*]config
[*]config-runtime
[*]mod_bwlimited
[*]mod_cgi
[*]mod_deflate
[*]mod_env
[*]mod_expires
[*]mod_headers
[*]mod_mpm_prefork
[*]mod_proxy
[*]mod_proxy_fcgi
[*]mod_proxy_http
[*]mod_proxy_wstunnel
[*]mod_ruid2
[*]mod_security2
[*]mod_ssl
[*]mod_unique_id
[*]tools
[/LIST]
PHP 7.4
[LIST]
[*]libc-client
[*]pear
[*]php-bcmath
[*]php-calendar
[*]php-cli
[*]php-common
[*]php-curl
[*]php-devel
[*]php-fpm
[*]php-ftp
[*]php-gd
[*]php-iconv
[*]php-imap
[*]php-litespeed
[*]php-mbstring
[*]php-mysqlnd
[*]php-pdo
[*]php-posix
[*]php-sockets
[*]php-xml
[*]php-zip
[*]runtime
[/LIST]
PHP 8.0
[LIST]
[*]libc-client
[*]pear
[*]php-bcmath
[*]php-calendar
[*]php-cli
[*]php-common
[*]php-curl
[*]php-devel
[*]php-fpm
[*]php-ftp
[*]php-gd
[*]php-iconv
[*]php-imap
[*]php-litespeed
[*]php-mbstring
[*]php-mysqlnd
[*]php-pdo
[*]php-posix
[*]php-sockets
[*]php-xml
[*]php-zip
[*]runtime
[/LIST]
Additional Packages
[LIST]
[*]apr
[*]apr-util
[*]brotli
[*]cpanel-tools
[*]documentroot
[*]libargon2
[*]libcurl
[*]libnghttp2
[*]libxml2
[*]libzip
[*]modsec-sdbm-util
[*]nghttp2
[*]oniguruma
[*]oniguruma-devel
[*]openssl
[*]openssl11
[*]php-cli
[*]php-cli-lsphp
[*]profiles-cpanel
[*]ruby24-ruby
[*]ruby24-ruby-irb
[*]ruby24-ruby-libs
[*]ruby24-rubygem-bigdecimal
[*]ruby24-rubygem-did_you_mean
[*]ruby24-rubygem-io-console
[*]ruby24-rubygem-json
[*]ruby24-rubygem-openssl
[*]ruby24-rubygem-psych
[*]ruby24-rubygem-rdoc
[*]ruby24-rubygems
[*]ruby24-runtime
[*]ruby27-libuv
[*]ruby27-mod_passenger
[*]ruby27-ruby
[*]ruby27-ruby-devel
[*]ruby27-ruby-irb
[*]ruby27-ruby-libs
[*]ruby27-ruby-wrapper
[*]ruby27-rubygem-bigdecimal
[*]ruby27-rubygem-did_you_mean
[*]ruby27-rubygem-io-console
[*]ruby27-rubygem-json
[*]ruby27-rubygem-openssl
[*]ruby27-rubygem-passenger
[*]ruby27-rubygem-psych
[*]ruby27-rubygem-rack
[*]ruby27-rubygem-rdoc
[*]ruby27-rubygems
[*]ruby27-runtime
[/LIST]
Have you tried reboot your server vps
 

cPRex

Jurassic Moderator
Staff member
Oct 19, 2014
12,481
1,966
363
cPanel Access Level
Root Administrator
Hey there! I did the following:

-created an account so I had something to log in to
-went to EA4 and installed those modules
-logged in to cPanel
-found Application Manager with this description: "This feature allows you to register, manage, and deploy your custom applications using Phusion Passenger."

I'm not sure what else would be missing from that configuration since you did everything correctly. Are there any logs in /usr/local/cpanel/logs/error_log when you access cPanel? If not, you can open a ticket with your host or with our team so we can check this out.
 

snb74883

Registered
Apr 21, 2022
2
0
1
Malaysia
cPanel Access Level
Root Administrator
So I solved the issue but with very weird steps:

If anyone out there experiences the same issue as me, try this

BRAND NEW SERVER:
1. Change Root Password
2. Open Terminal and run
yum install ea-ruby27-mod_passenger ea-apache24-mod_env ea-nodejs16
3. Verify that WHM > Feature Manager > Edit Default - has Application Manager Checked
4. Create an Account using the Default Package
5. On top right of WHM it should say something like update to v102.0.11
6. Run the update
7. Voilla, Application Manager is now available.

Very very very weird. Not sure what's going on, probably a bug with the previous version, v100.0.12.