Passive FTP for cpbackup not working

dansgalaxy

Well-Known Member
Jan 29, 2007
91
0
156
Reading, UK
cPanel Access Level
Root Administrator
I have got some FTP backup with a new server, but can't get it working, as soon as it enters Passive it chokes.

It's running on a custom port, all info is fine.

Server running CentOS & CSF. It works when firewall is disabled, so that's obviously the issue.

How can I set it up so Passive FTP OUT works with the firewall?
 

BlaineM.

cPanel QA Analyst
Apr 4, 2011
31
0
56
Houston, TX
cPanel Access Level
Root Administrator
Hey Dan, there are a couple settings you'll need to change to allow Passive FTP.

First, you'll need to tell PureFTPd and ProFTP what ports to use for Passive FTP.

for PureFTPd edit /etc/pure-ftpd.conf, uncomment the following line, and set the port range you'll be using.
# PassivePortRange 30000 35000

for ProFTP, do the same for /etc/proftpd.conf.
# PassivePorts 30000 35000

Then, you'll need to tell CSF to allow that port range through your firewall.

edit /etc/csf/csf.conf and add the range as StartingPort:EndingPort, like the following.
# Allow incoming TCP ports
TCP_IN = "20,21,22,25,53,80,110,30000:35000"

Finally, you'll need to restart the services.

service csf restart
service pureftpd restart
or
service proftpd restart