illuminerdi

Registered
Apr 24, 2019
1
0
1
United States
cPanel Access Level
Root Administrator
Ran into this problem earlier on cPanel v78.0.21 on Centos 7.6 using latest Chrome on Mac Mojave:

1) Log into WHM as root
2) List Accounts
3) Create new account/user
4) Fill in all fields. Due to recent internal changes, I used, for the first time on a cpanel, a passphrase (4 words, no spaces, no punctuation) for the password
5) WHM reports that account was created successfully
6) Attempt to log in via the account I just created (as in via the login screen, NOT by clicking the "cp" icon in Account List)
7) Login fails - bad password. Tried both cutting and pasting and manually typing in password
8) Tried using WHM to reset the password, same result
9) Logged into the user's cPanel via the "cP" icon in the account list
10) Used reset password function via user's cPanel
11) Was now able to log in successfully

It seems like WHM does not like passphrases for some reason or is otherwise being problematic about them. There is a possibility it's something on my end, but most other functionality works fine for me via Chrome, so I'm not sure if it's something to do with the way Chrome handles the password field or character input.

Just wanted to report this bug - obviously I've found a way around it, but others may run into this issue?
 
Last edited by a moderator:

cPanelMichael

Administrator
Staff member
Apr 11, 2011
47,913
2,205
363
Hello @illuminerdi,

Can you confirm if the issue persists when using Chrome incognito mode, or when temporarily disabling any Chrome extensions installed on your web browser? I was unable to reproduce the issue in testing, and it seems like it might relate to the LastPass browser extension for Chrome that you referenced in your other support request.

Thank you.