The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Password authentication failing after tonight's update

Discussion in 'General Discussion' started by Curious Too, Aug 24, 2005.

  1. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Pure-ftp Password authentication failing after tonight's update

    I have several servers that I can no longer access via ftp after tonight's cPanel update -- the error message in the server's message log says "authentication failed." Resetting the password in whm doesn't work. Is anyone else experiencing this?
     
    #1 Curious Too, Aug 24, 2005
    Last edited: Aug 25, 2005
  2. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    There was a pure-ftpd update tonight -- it went well on some servers and on others it was hosed. I had to switch to proftpd on those servers. The only clue is the " Authentication failed for user [username]" in the server's message log. Re-installing pure-ftpd does not help.
     
  3. DigiCrime

    DigiCrime Well-Known Member

    Joined:
    Nov 27, 2002
    Messages:
    399
    Likes Received:
    0
    Trophy Points:
    16
    i switched mine ti pro then back to pure then hit sync ftp passwords and it worked
     
  4. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    That didn't work for me.
     
  5. ehpmahesh

    ehpmahesh Well-Known Member

    Joined:
    Jul 3, 2004
    Messages:
    74
    Likes Received:
    0
    Trophy Points:
    6
    I think you passwd file is get corrpeted. Try to restore it from the backup.
     
  6. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    Proftpd works -- pure-ftpd does not. This happened on every server that had pure-ftpd updated during cPanel's update. I don't think it's the password file, Besides, every other login works, it's only pure-ftpd that's broken.
     
  7. Suter Rainer

    Suter Rainer Well-Known Member

    Joined:
    Jul 24, 2004
    Messages:
    55
    Likes Received:
    0
    Trophy Points:
    6
    i have the same issue over 6 servers
     
  8. BianchiDude

    BianchiDude Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2005
    Messages:
    619
    Likes Received:
    0
    Trophy Points:
    16
    I am having this issue on over 30 servers. We need a fix, like now!

    Is it safe to run proftpd? I understand there is a root exploit out for it, if hackers are going to hit it would seem like now is the time to do it. I dont know about you but Im not switching to proftpd.
     
    #8 BianchiDude, Aug 25, 2005
    Last edited: Aug 25, 2005
  9. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider
    Are you running EDGE?
     
  10. BianchiDude

    BianchiDude Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2005
    Messages:
    619
    Likes Received:
    0
    Trophy Points:
    16
    a
    /scripts/updatenow
    /scritps/upcp
    seems to fix this, can anyone confirm this?
     
  11. BianchiDude

    BianchiDude Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2005
    Messages:
    619
    Likes Received:
    0
    Trophy Points:
    16
    Yes, EDGE, I'd like to run stable but everytime I write in for support they say upgrade to EDGE

    Do you fix something after lastnights upgrade? If so just say we have fixed this, please update there is a new Edge release.

    Thanks
     
  12. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider

    If you submit a ticket, (if you already have, just let me know the #). I will look at the server in question ASAP.
     
  13. BianchiDude

    BianchiDude Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2005
    Messages:
    619
    Likes Received:
    0
    Trophy Points:
    16
    Its working after my cpanel update.

    Is proftpd safe to use?
     
  14. tweekmonster

    tweekmonster Registered

    Joined:
    Oct 11, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I'm running EDGE too, and /usr/sbin/pureauth seems to be different now. Logging in seems to work if the account owner adds @theirdomain.tld at the end of their login name.

    And this works for me.
     
  15. salvatore333

    salvatore333 Well-Known Member

    Joined:
    Mar 27, 2003
    Messages:
    233
    Likes Received:
    0
    Trophy Points:
    16
    This fixed it for me:

    /scripts/updatenow
    /scritps/upcp

    I am running edge. Thanks
     
  16. cPanelNick

    cPanelNick Administrator
    Staff Member

    Joined:
    Mar 9, 2015
    Messages:
    3,426
    Likes Received:
    2
    Trophy Points:
    38
    cPanel Access Level:
    DataCenter Provider

    Do the main users have to user the @theirdomain.tld , or just the sub users?
     
  17. Curious Too

    Curious Too Well-Known Member

    Joined:
    Aug 31, 2001
    Messages:
    427
    Likes Received:
    0
    Trophy Points:
    16
    cPanel Access Level:
    Root Administrator
    I opened a ticket for this problem, ticket number is 109547.
     
  18. hostit1

    hostit1 Well-Known Member

    Joined:
    Jul 24, 2003
    Messages:
    88
    Likes Received:
    0
    Trophy Points:
    0
    Venting

    I am really frustrated with cPanel at the moment.

    We had an issue with dnsadmin killing 7 of our dns clusters, so we were told to upgrade machines to stable version.

    Then another issue started to occur and we were told to upgrade to edge. Now we have about 30 servers that are having FTP authentication issues.

    While I believe cPanel is one of the best webhosting controllers, I believe that they should implement some change management and better testing before the software is released to the public.

    Maybe I am expecting too much, but these upgrades are a pain when they just cause more problems. It is costly for us in regards to man-power fixing these issues making the overall value of cpanel lower. This decreases our margins!!!

    We have our cpanel update set to manual. We implemented this about a year and a half ago when we had sites on a server defaced due to a "password change" flaw in the cPanel software. How is it that the cpanel coding can get updated with this cpanel update flag set to manual?

    For example, in our testing environment, we had 3 servers that we upgraded to the edge version (e59). FTP and everything seemed to work properly yesterday after 6 hours of testing. We then promoted 10% of production servers to this edge build and FTP was working fine yesterday evening, but now, 30 servers that received the update yesterday (that were working fine), now has the FTP login authentication issue.

    The /scripts/updatenow and /scripts/upcp did resolve the problem, but we really need a more "stable" cpanel system. We only upgraded to edge because it fixed other broken aspects of the software and we were advised to update to the edge version by support.

    I am hoping that some very senior administrators can offer some ideas or helpful suggestions on how we can avoid these issues with cpanel updates breaking things when all our servers are set to update manually.

    I am aware that the folks at cPanel are very busy and helpful in our time of need (and I appreciate that). I am not trying to bash them, but I do want to direct my frustrations so that they can make postive changes in their software updates that they push out to hosting providers.


    Any suggestions are appreciated,

    Mark Langston
    Path Host - http://pathhost.net
     
  19. BianchiDude

    BianchiDude Well-Known Member
    PartnerNOC

    Joined:
    Jul 2, 2005
    Messages:
    619
    Likes Received:
    0
    Trophy Points:
    16
    I totally agree, cpanel staff runs the Beta version, I find it hard to believe they didnt get this error. Email was completely down a few weeks ago and now FTP went complete down. The stable release is kinda pointless as it takes too long for bug fixes and when you write into support they say upgrade to edge. What needs to be done to get better testing? Email and FTP are mission critical, my customers find it unacceptable that they go down.
     
    #19 BianchiDude, Aug 25, 2005
    Last edited: Aug 25, 2005
  20. tweekmonster

    tweekmonster Registered

    Joined:
    Oct 11, 2003
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    All users have to. Even the ones that were not created though cpanel; so they just fail no matter what. But /scripts/updatenow;/scritps/upcp seemed to fix the problem.

    It looks like the pureauth is checking /etc/proftpd/accountuser for the user/password instead of /etc/proftpd/passwd.vhosts. I guessed that the script needed the @theirdomain.tld to find the right shadow file.
     
Loading...

Share This Page