The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Password bug in cPanel->MySQL Databases

Discussion in 'Database Discussions' started by sven4o, Oct 6, 2011.

  1. sven4o

    sven4o Member

    Joined:
    May 21, 2007
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have come upon a bug in cPanel->MySQL Databases.

    When I add a user and include the following pattern in the password field _0 the password is changed.

    For example if I enter the following password in the Add New User password field:

    pass_0PASS

    it is transformed to:

    passCpanel::Locale::en=HASH(0xa5c1be0)PASS

    The confirmation message is:

    Added user sgtest_test with password passCpanel::Locale::en=HASH(0xa5c1be0)PASS.

    The cPanel version is 11.30.1 (build 4).

    Could you please advise what is causing the issue and how to solve it.

    Best Regards,

    Svetlio
     
    #1 sven4o, Oct 6, 2011
    Last edited: Oct 6, 2011
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,470
    Likes Received:
    198
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Are you using the x3 theme for this account? If yes, this sounds like a defect to me and should be reported if you would please, here: http://go.cpanel.net/bugs


    Thanks!
     
  3. sven4o

    sven4o Member

    Joined:
    May 21, 2007
    Messages:
    19
    Likes Received:
    0
    Trophy Points:
    1
    Thank you.

    The bug report has been sent.

    Best Regards,

    Svetlio
     
Loading...

Share This Page