The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Password protect and indexing not working

Discussion in 'General Discussion' started by Stobe, Jan 6, 2005.

  1. Stobe

    Stobe Member

    Joined:
    Sep 26, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Hello,

    I have a client that tried to password protect a directory, and tried to turn indexing off, and it did not work.

    I checked his .htaccess file, and it looked fine. Here it is:

    Code:
    AuthType Basic
    
    AuthName "test"
    
    AuthUserFile "/home/username/.htpasswds/Test/passwd"
    
    
    require valid-user
    Options All -Indexes
    This is the .htaccess file within the /Test directory.

    Do you see anything wrong with it?

    Thanks in advance,
    Stobe
     
  2. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,381
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    What error message is displayed? What does the Apache error log show when trying to access this directory?
     
  3. Stobe

    Stobe Member

    Joined:
    Sep 26, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    There's no errors at all.

    It simply lets you go right to the /Test directory and see all files there, w/o any index file present.

    -Stobe
     
  4. Stobe

    Stobe Member

    Joined:
    Sep 26, 2003
    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    1
    Tried to setup a test on one of my domains, and it did the same thing, so it is server wide?

    Did a test on another server I have, and it worked great. Both are running latest cpanel.

    -Stobe
     
  5. sparek-3

    sparek-3 Well-Known Member

    Joined:
    Aug 10, 2002
    Messages:
    1,381
    Likes Received:
    23
    Trophy Points:
    38
    cPanel Access Level:
    Root Administrator
    Try restarting your browser or using a different browser to insure that the login information is not stored in your browser.
     
Loading...

Share This Page