The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Password Protect Won't Unlock?!

Discussion in 'Security' started by daddyward, Mar 20, 2009.

  1. daddyward

    daddyward Registered

    Joined:
    Mar 20, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I need a little help please.

    I have recently had a site protected and had a subdomain installed, which then protected that site too, which I didn't want. I turned the password protection off and delted the users etc, so that it was open to all, but it now asks for the username and password on all sites and admin pages even though I have taken the passwords off?! I have deleted the IE cache on 3 different PC's and even used Firefox, but it is still doing the same.

    Can anybody help me out with this please as it's doing my head in now!
     
  2. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,449
    Likes Received:
    195
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
    Your host can assist you with this easy enough.

    Short of that you might want to have a look at the .htaccess file in the root of the account. This is a hidden "dot" file .htaccess so you may not see it unless your FTP client is set for that, or, you've selected to show dot files when first entering the File Manager window in your cPanel.

    You might try simply renaming that file to .httaccess.txt to disable it for a moment, then try your site. If it works, good.

    You have two options then. open that file to edit, and delete all contents, or, since it may have other stuff in it for your website, fine this line in it:


    AuthUserFile "/home/yournamehere/.htpasswds/public_html/passwd"

    And remove it, or remark it out with this -> #
    So it looks like this:

    #AuthUserFile "/home/yournamehere/.htpasswds/public_html/passwd"

    Save and close. Then rename it back to .htaccess (without the .txt stuff)

    Check to see if there is a file similar in your sub.domain directory as well.
     
  3. daddyward

    daddyward Registered

    Joined:
    Mar 20, 2009
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    1
    I just had a fiddle about with the files like you suggested and I've put a # infront of the 4 lines that are in the .htaccess file and it worked!

    You are a Superstar! Thanks!
     
Loading...

Share This Page