The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Password protected directories, Not working

Discussion in 'General Discussion' started by Speedy059, Apr 22, 2009.

  1. Speedy059

    Speedy059 Well-Known Member

    Joined:
    Jul 10, 2007
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    6
    When I set the options to password protect a directory with a username, nothing happens and it's not working. I tried restarting the apache service and the server itself. Any idea why my password protected directories aren't working? Is there a setting in WHM I need to enable for it to start working?

    Thanks!
     
  2. mtindor

    mtindor Well-Known Member

    Joined:
    Sep 14, 2004
    Messages:
    1,279
    Likes Received:
    36
    Trophy Points:
    48
    Location:
    inside a catfish
    cPanel Access Level:
    Root Administrator
    No settings in WHM that would change anything. Are you running Frontpage on that site (i.e. do you have Frontpage Extensions installed) ? If so, then you likely can't password protect directories. If Frontpage Extensions are installed, the customer can password protect via Frontpage.

    Mike
     
  3. ChrisRHS

    ChrisRHS Well-Known Member

    Joined:
    Jul 12, 2006
    Messages:
    292
    Likes Received:
    5
    Trophy Points:
    18
    I've had an issue with this before, and what was happening is that the .htpasswd file was not in the location that the .htaccess was looking for. Check your .htaccess, and ensure that the file location is correct.
     
Loading...

Share This Page