Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

PayPal SDK's and cPanel

Discussion in 'Workarounds and Optimization' started by Mirageboss, Mar 15, 2017.

Tags:
  1. Mirageboss

    Mirageboss Registered

    Joined:
    Dec 11, 2016
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Location:
    Australia
    cPanel Access Level:
    Root Administrator
    So I'm running a custom coded system utilising Laravel Framework and PayPal's Rest API SDK.

    The issue I have found is that PayPal doesn't like cPanel's OpenSSL version. How do I go about manually upgrading OpenSSL to the required version? Previously, in my previous thread (located here) CURL was part of the issue, but now it seems OpenSSL is the final problem.


    Below is an output from a PayPal REST API Sample Test:
    1. FAILURE: SECURITY WARNING: TLSv1.2 is not supported on this system. Please upgrade your curl to at least 7.34.0.
    - Current Curl Version: 7.38.0
    - Current OpenSSL Version:OpenSSL/1.0.1e (Failed)


    Anyone able to assist with this final problem?
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    43,870
    Likes Received:
    1,811
    Trophy Points:
    363
    cPanel Access Level:
    Root Administrator
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...
Similar Threads - PayPal SDK's cPanel
  1. Mirageboss
    Replies:
    3
    Views:
    568

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice