MaRiOsGR66

Well-Known Member
Feb 18, 2011
112
1
68
cPanel Access Level
Root Administrator
Hello,

one of my customers try to install Typo3 and it gives this message:

PCRE version too low
Your PCRE version 8.32 2012-11-30 is too old.
TYPO3 CMS may trigger PHP segmentantion faults with this version.
Update to at least PCRE 8.38

How can I upgrade PCRE ? I tried from EasyApache4 but I cannot find it there.

Thank you.
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,273
1,282
313
Houston
Hello @MaRiOsGR66


This is something provided by your OS and Unfortunately a higher version of PCRE is not available on the CentOS 7 Base repo and the only way you'd be able to install it from what I can see is to compile it yourself though this would be unsupported.
 

kawasakai

Active Member
Sep 17, 2015
44
3
58
Germany
cPanel Access Level
Root Administrator
Hello @MaRiOsGR66


This is something provided by your OS and Unfortunately a higher version of PCRE is not available on the CentOS 7 Base repo and the only way you'd be able to install it from what I can see is to compile it yourself though this would be unsupported.
CentOS provides pcre2 which is version "10.23". Question here is, if it is save to install and would it be used by typo3 or other cms?
 

cPanelLauren

Product Owner
Staff member
Nov 14, 2017
13,273
1,282
313
Houston