The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pdo errors

Discussion in 'General Discussion' started by Zion Ahead, May 29, 2012.

  1. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Centos / cPanel

    root@server [~]# /scripts/phpextensionmgr list
    Available Extensions:
    EAccelerator
    IonCubeLoader
    Zendopt
    Xcache
    SourceGuardian
    PHPSuHosin


    How do I resolve these errors? I have both PDO modules enabled in easyapache (pdo and pdo mysql)
     
  2. Zion Ahead

    Zion Ahead Well-Known Member

    Joined:
    Nov 10, 2006
    Messages:
    347
    Likes Received:
    0
    Trophy Points:
    16
    Would appreciate help on this please
     
  3. Infopro

    Infopro cPanel Sr. Product Evangelist
    Staff Member

    Joined:
    May 20, 2003
    Messages:
    14,470
    Likes Received:
    199
    Trophy Points:
    63
    Location:
    Pennsylvania
    cPanel Access Level:
    Root Administrator
    Twitter:
  4. cPanelTristan

    cPanelTristan Quality Assurance Analyst
    Staff Member

    Joined:
    Oct 2, 2010
    Messages:
    7,623
    Likes Received:
    21
    Trophy Points:
    38
    Location:
    somewhere over the rainbow
    cPanel Access Level:
    Root Administrator
    If you do not have pdo_pgsql.so in the PHP extensions directory, then you would need to comment out the line in /usr/local/lib/php.ini file:

    ;extension = pdo_pgsql.so

    Or something along those lines. You can find it using:

    Code:
    grep pdo_pgsql /usr/local/lib/php.ini
    Once you comment out the line, simply restart Apache.

    Of note, while we provide pgsql, pdo, pdo mysql, we do not provide pdo pgsql in EasyApache's PHP Exhaustive Options List as a PHP module.

    Thanks!
     
Loading...

Share This Page