Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

PDO+PDO_MYSQL on php5.2.1+php-suexec (php-cgi)?

Discussion in 'General Discussion' started by PondRicefied, May 11, 2007.

  1. PondRicefied

    PondRicefied Well-Known Member

    Joined:
    Dec 13, 2004
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    156
    I have installed php5.2.x+php-suexec from WHM.
    The now problem is being unable to use pdo_mysql.

    Can it be filled with the following command after installing as a required compile option from WHM?
    ---
    [/home/cpapachebuild/buildapache/php-5.2.1]# ./configure --with-pdo=shared --with-pdo-mysql=shared
    ---
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  2. PondRicefied

    PondRicefied Well-Known Member

    Joined:
    Dec 13, 2004
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    156
    All is an error although I tried the following thing. (It seems that installation is completed.)

    -- run ---
    $ pecl install -f pdo_mysql

    or

    PDO_MYSQL-1.0.2/$ phpize
    PDO_MYSQL-1.0.2/$ ./configure --with-pdo-mysql=shared
    ----------
    |
    v
    -- Apache Log ---
    /usr/bin/php: error while loading shared libraries: /usr/local/lib/php/extensions/no-debug-non-zts-20060613/pdo_mysql.so: undefined symbol: php_pdo_declare_long_constant
    --------------------

    Anyone Please.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  3. PondRicefied

    PondRicefied Well-Known Member

    Joined:
    Dec 13, 2004
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    156
    I have not tried the following. I am it worried whether it succeeds at this step.

    --- After WHM->Apache Update->Load Previouse Config->Start Build ---
    /home/cpapachebuild/buildapache/php-5.2.1 $ ./config.nice --with-pdo-mysql=shared
    $ pecl install -f pdo_mysql
    --------------------------------------------------------------------------------

    Was someone installable at this step?
    Or is it unable in PHP of a cgi module?
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. PondRicefied

    PondRicefied Well-Known Member

    Joined:
    Dec 13, 2004
    Messages:
    52
    Likes Received:
    0
    Trophy Points:
    156
    It ran without 'pecl install pdo' by 'pecl install pdo_mysql'.

    thak you.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice