The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

PDO_Mysql, Apache 2.2, Mysql 5, PHP 5.2.4, Not Functional

Discussion in 'EasyApache' started by geedew, Sep 19, 2007.

  1. geedew

    geedew Registered

    Joined:
    Jun 10, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    I have posted on this topic before, looking for help with the new easyapache3.

    I need to use PDO support for mysql. The pdo drivers seem to install fine with sqlite running on
    WHM 11.11.0 cPanel 11.12.0-C17116
    REDHAT Enterprise 4 i686 on standard - WHM X v3.1.0
    with the standard installation mehod of easyapache3. The issue is when I try to install support for the pdo_mysql.

    In other posts I created a working method for handling this and it worked great. But now, with the newer installer, and even compensating for the moved php directory, my method fails to install pdo_mysql. This is a real bummer, as the pecl just errors out with the autoconf not found (presumably something to do with tmp not being mounted as writeable). Also, the manual install (./configure blah...) goes through without any errors... yet the module is not installed, in fact, breaks pdo_sqlite.

    Any body have any way to solve this... without hacking at it?

    Thanks.
     
  2. cPDan

    cPDan cPanel Staff
    Staff Member

    Joined:
    Mar 9, 2004
    Messages:
    711
    Likes Received:
    4
    Trophy Points:
    18
    Do you mean PDO=mysql for PHP? If so I believe that (and other otps) have moved to PECL/PEAR
     
  3. geedew

    geedew Registered

    Joined:
    Jun 10, 2007
    Messages:
    3
    Likes Received:
    0
    Trophy Points:
    1
    Yes, I will check out more on the pecl issue as far as tmp not being executable, and report back if I get it.
     
Loading...

Share This Page