The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

pdo_pgsql error

Discussion in 'General Discussion' started by daviem, Oct 1, 2014.

  1. daviem

    daviem Member

    Joined:
    Jan 13, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi, Im having a problem with installing on whm with centos 6.5 would appr3eciate any advice, running php 5.4.33.

    With this command pecl install pdo_pgsql I keep getting this error

    /root/tmp/pear/PDO_PGSQL/pdo_pgsql.c:22:20: error: config.h: No such file or directory
    make: *** [pdo_pgsql.lo] Error 1
     
  2. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,683
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Hello :)

    Please install this module through EasyApache under the "Exhaustive Options List" for PHP. Make sure you have installed PostgreSQL on your server before running EasyApache.

    Thank you.
     
  3. daviem

    daviem Member

    Joined:
    Jan 13, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Hi, I have done all that the module did not show under that list to install andvia ssh the error still showed, so I downgraded to php 5.3 and completed the installation via ssh and then easyapache and it worked I then upgraded to php 5.4.3 again and everything seemed to work still, there is still a problem however users cannot connect to any pgsql databases even though checking via ssh shows its running, a typical error is cannot connect to database and FATAL: no pg_hba.conf entry for host "::1"

    Thanks
     
  4. daviem

    daviem Member

    Joined:
    Jan 13, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Any help regarding this problem with cpanel? as I now have internal server errors showing
     
  5. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,683
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    You can browse to the following option in WHM and click on "Install Config":

    "WHM Home » SQL Services » Configure PostgreSQL"

    You can update the PostgreSQL password, and also check your script's configuration file to see what settings you are using for "Host".

    Thank you.
     
  6. daviem

    daviem Member

    Joined:
    Jan 13, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Thank you, I completely remove postgresql then rebuilt Apache to fix the internal errors that appeared I then installed Postgreql via this method https://documentation.cpanel.net/pages/viewpage.action?pageId=361925 I have then configured PostgreSQL via "WHM Home » SQL Services » Configure PostgreSQL"

    What do I need to do now? rebuild apache with the module selected?

    Thanks
     
  7. daviem

    daviem Member

    Joined:
    Jan 13, 2014
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Well I rebuilt apache after installing PostgreSQL using the cpanel script and followed everything and again pgsql in not loaded under php and not working but showing in WHM and cpanel as working this is on cento 6.5
     
  8. cPanelMichael

    cPanelMichael Forums Analyst
    Staff Member

    Joined:
    Apr 11, 2011
    Messages:
    30,683
    Likes Received:
    654
    Trophy Points:
    113
    cPanel Access Level:
    Root Administrator
    Feel free to open a support ticket using the link in my signature so we can take a closer look. You can post the ticket number here so we can update this thread with the outcome.

    Thank you.
     
Loading...

Share This Page