The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Pecl module installing fails

Discussion in 'General Discussion' started by nikohal, Oct 13, 2011.

  1. nikohal

    nikohal Member

    Joined:
    Oct 12, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    Can someone help in this case. When I try to install pecl package I get follow error.downloading pecl_http-1.7.1.tgz ...Starting to download pecl_http-1.7.1.tgz (174,098 bytes).....................................done: 174,098 bytesCould not get contents of package "/root/tmp/pear/cache/pecl_http-1.7.1.tgz". Invalid tgz file.Download of "pecl/pecl_http" succeeded, but it is not a valid package archiveError: cannot download "pecl/pecl_http"Download failedinstall failedThe pecl_http.so object is not in /usr/local/lib/php/extensions/no-debug-non-zts-20090626No matter what package it is. All other package does the same.
     
  2. morissette

    morissette Well-Known Member

    Joined:
    May 24, 2009
    Messages:
    119
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    Austin, TX
    cPanel Access Level:
    Root Administrator
    root@freedom:~# pecl search http
    Retrieving data...0%
    MATCHED PACKAGES, CHANNEL PECL.PHP.NET:
    =======================================
    PACKAGE STABLE/(LATEST) LOCAL
    pecl_http 2.0.0dev2 (devel) Extended HTTP Support
    root@freedom:~# ssh antiamerican.org
    Last login: Thu Oct 13 13:22:54 2011 from 72.177.75.155
    root@vps3396 [~]# pecl install pecl_http
    downloading pecl_http-1.7.1.tgz ...
    Starting to download pecl_http-1.7.1.tgz (174,098 bytes)
    .....................................done: 174,098 bytes
    71 source files, building
    running: phpize
    Configuring for:
    PHP Api Version: 20041225
    Zend Module Api No: 20060613
    Zend Extension Api No: 220060519
    whether to enable cURL HTTP requests; specify libcurl directory [yes] : yes
    whether to enable support for gzencoded/deflated message bodies; specify zlib directory [yes] : yes
    whether to enable response content type guessing; specify libmagic directory [no] :
    whether to depend on extensions which have been built shared [yes] :
    building in /var/tmp/pear-build-root/pecl_http-1.7.1
    running: /root/tmp/pear/pecl_http/configure --with-http-curl-requests --with-http-zlib-compression --with-http-magic-mime=no --with-http-shared-deps
    checking for egrep... grep -E
    checking for a sed that does not truncate output... /bin/sed
    checking for cc... cc
    checking for C compiler default output file name... a.out

    I am unable to replicate you can always manually install it using:

    cd /usr/src
    wget http://pecl.php.net/get/pecl_http-1.7.1.tgz
    tar xzf pecl_http-1.7.1.tgz
    cd pecl_http-1.7.1
    phpize
    ./configure
    make && make install
     
  3. nikohal

    nikohal Member

    Joined:
    Oct 12, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    But why I get in cPanel that error? It is bug in Centos 5.7 or in Cpanel?
     
  4. nikohal

    nikohal Member

    Joined:
    Oct 12, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    I get same error when I try install pear modules

    root@theocbase [/usr/local/lib]# pear install Auth
    WARNING: "pear/DB" is deprecated in favor of "pear/MDB2"
    WARNING: "pear/MDB" is deprecated in favor of "pear/MDB2"
    WARNING: "pear/HTTP_Client" is deprecated in favor of "pear/HTTP_Request2"
    Did not download optional dependencies: pear/Log, pear/File_Passwd, pear/Net_POP3, pear/DB, pear/MDB, pear/MDB2, pear/Auth_RADIUS, pear/Crypt_CHAP, pear/File_SMBPasswd, pear/HTTP_Client, pear/SOAP, pear/Net_Vpopmaild, pecl/vpopmail, pecl/kadm5, use --alldeps to download automaticallycpanel/3rdparty/etc/roundcube/php.ini
    pear/Auth can optionally use package "pear/Log" (version >= 1.9.10)
    pear/Auth can optionally use package "pear/File_Passwd" (version >= 1.1.0)
    pear/Auth can optionally use package "pear/Net_POP3" (version >= 1.3.0)
    pear/Auth can optionally use package "pear/DB" (version >= 1.6.0)
    pear/Auth can optionally use package "pear/MDB"d
    pear/Auth can optionally use package "pear/MDB2" (version >= 2.0.0RC1)
    pear/Auth can optionally use package "pear/Auth_RADIUS"
    pear/Auth can optionally use package "pear/Crypt_CHAP" (version >= 1.0.0)
    pear/Auth can optionally use package "pear/File_SMBPasswd" (version >= 1.0.0)
    pear/Auth can optionally use package "pear/HTTP_Client" (version >= 1.1.0)
    pear/Auth can optionally use package "pear/SOAP" (version >= 0.9.0)
    pear/Auth can optionally use package "pear/Net_Vpopmaild" (version >= 0.1.0)
    pear/Auth can optionally use package "pecl/vpopmail" (version >= 0.2)
    pear/Auth can optionally use package "pecl/kadm5" (version >= 0.2.3)
    pear/Auth can optionally use PHP extension "saprfc"
    pear/Auth can optionally use PHP extension "soap"
    downloading Auth-1.6.4.tgz ...
    Starting to download Auth-1.6.4.tgz (56,048 bytes)
    .............done: 56,048 bytes
    Could not get contents of package "/root/tmp/pear/cache/Auth-1.6.4.tgz". Invalid tgz file.
    Download of "pear/Auth" succeeded, but it is not a valid package archive
    Error: cannot download "pear/Auth"
    Download failed
    install failed
     
  5. nikohal

    nikohal Member

    Joined:
    Oct 12, 2011
    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    cPanel Access Level:
    Root Administrator
    It seems that the reason for the PHP version. I Downgrade 5.3.8 -> 5.3.6 and everything works
     
Loading...

Share This Page