The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Perl 5.8.8 problems

Discussion in 'General Discussion' started by Mariusz Jokiel, May 26, 2007.

  1. Mariusz Jokiel

    Mariusz Jokiel Active Member

    Joined:
    Nov 8, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Hi,

    I tried to install perl 5.8.8 ( http://forums.cpanel.net/showthread.php?t=66166)

    and now in yum i have:

    --> Package glibc-devel.i386 0:2.3.4-2.36Error: Missing Dependency: /usr/bin/perl is needed by package gnupg
    Error: Missing Dependency: perl(Getopt::Std) is needed by package gnupg
    Error: Missing Dependency: perl is needed by package gd-progs
    Error: Missing Dependency: /usr/bin/perl is needed by package gd-progs
    Error: Missing Dependency: perl(strict) is needed by package gd-progs
    Error: Missing Dependency: /usr/bin/perl is needed by package sharutils
    set to be updated

    Best regards,
    Mariusz Jokiel
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
  3. Mariusz Jokiel

    Mariusz Jokiel Active Member

    Joined:
    Nov 8, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    Thanks, but I understand that I should reinstall perl with some older version of perl.
    I found perl 5.8.5 on centos but when i am trying to install older version:

    Retrieving http://mirror.centos.org/centos-4/4.5/os/i386/CentOS/RPMS/perl-Filter-1.30-6.i386.rpm
    error: Failed dependencies:
    perl >= 0:5.002 is needed by perl-Filter-1.30-6.i386
    perl(Carp) is needed by perl-Filter-1.30-6.i386
    perl(Config) is needed by perl-Filter-1.30-6.i386
    perl(DynaLoader) is needed by perl-Filter-1.30-6.i386
    perl(Exporter) is needed by perl-Filter-1.30-6.i386
    perl(strict) is needed by perl-Filter-1.30-6.i386
    perl(vars) is needed by perl-Filter-1.30-6.i386
    perl(warnings) is needed by perl-Filter-1.30-6.i386
    Suggested resolutions:
    /home/buildcentos/CENTOS/en/4.0/i386/CentOS/RPMS/perl-5.8.5-36.RHEL4.i386.rpm
    root@f1 [/scripts/perl588installer]#


    What to do if i have already installed perl 5.8.8 on centos.
     
  4. rone

    rone Well-Known Member

    Joined:
    Jan 14, 2007
    Messages:
    179
    Likes Received:
    0
    Trophy Points:
    16
    Location:
    The Netherlands
    cPanel Access Level:
    Root Administrator
    This is all you need to do:

    wget http://layer2.cpanel.net/perl588installer.tar.gz
    tar xfz perl588installer.tar.gz
    cd perl588installer
    ./install
    /usr/local/cpanel/bin/checkperlmodules


    Please stop experimenting with your server if you don't know what you are doing.
     
  5. Mariusz Jokiel

    Mariusz Jokiel Active Member

    Joined:
    Nov 8, 2004
    Messages:
    27
    Likes Received:
    0
    Trophy Points:
    1
    You are wrong, you should:

    rpm -Uvh --justdb --nodeps http://mirror.centos.org/centos-4/4....RHEL4.i386.rpm

    and then


    wget http://layer2.cpanel.net/perl588installer.tar.gz
    tar xfz perl588installer.tar.gz
    cd perl588installer
    ./install
    /usr/local/cpanel/bin/checkperlmodules
     
Loading...

Share This Page