Please whitelist cPanel in your adblocker so that you’re able to see our version release promotions, thanks!

The Community Forums

Interact with an entire community of cPanel & WHM users!

Perl 5.8.8 upgrade

Discussion in 'General Discussion' started by fleksi, Mar 24, 2007.

  1. fleksi

    fleksi Well-Known Member

    Joined:
    Sep 17, 2003
    Messages:
    125
    Likes Received:
    0
    Trophy Points:
    166
  2. maynards

    maynards Member

    Joined:
    Mar 28, 2005
    Messages:
    14
    Likes Received:
    0
    Trophy Points:
    151
    I was wondering the same thing
     
  3. carluk

    carluk Well-Known Member

    Joined:
    Sep 2, 2003
    Messages:
    162
    Likes Received:
    0
    Trophy Points:
    166
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  4. cooldude7273

    cooldude7273 Well-Known Member

    Joined:
    Jan 11, 2004
    Messages:
    359
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Roswell, GA
    Doesn't seem to be a massively critical update, but it fixes and updates a variety of things.

    I'm upgrading now and will let you know how it goes.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  5. cooldude7273

    cooldude7273 Well-Known Member

    Joined:
    Jan 11, 2004
    Messages:
    359
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Roswell, GA
    5.8.8 seems to have installed successfully and working fine, but cP seems to be bugged and shows that the installed version is 5.8.7, I'll report back when I find out whats up.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  6. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    782
    Likes Received:
    5
    Trophy Points:
    318
    Location:
    N.W. Iowa
    try deleting the file in the /home/USERNAME /.cpanel-datastore/_usr_bin_perl_-v then relogin Cpanel, then it should show the right version.

    did you happen to notice if you lost any Perl modules previously installed under 5.8.7 ver??

    Mickalo
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  7. cooldude7273

    cooldude7273 Well-Known Member

    Joined:
    Jan 11, 2004
    Messages:
    359
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Roswell, GA
    Indeed, that did update the version number for the account I tried it with to 5.8.8.

    I'd hate to have to do this for each account though, I'm looking into a way to do it for all accounts, I'll get back to you all again. :)

    If I did lose any perl modules (which I don't think I did), there was not a significant amount, as the list of installed ones is insanely long still. :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  8. cooldude7273

    cooldude7273 Well-Known Member

    Joined:
    Jan 11, 2004
    Messages:
    359
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Roswell, GA
    Ok, I got all of the accounts to update.

    If anyone wants a professional update to 5.8.8, I'll do it for $5. :)
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  9. Spiral

    Spiral BANNED

    Joined:
    Jun 24, 2005
    Messages:
    2,023
    Likes Received:
    8
    Trophy Points:
    193
    Easy enough ...

    rm -f /home/*/.cpanel-datastore/_usr_bin_perl_-v
     
  10. cooldude7273

    cooldude7273 Well-Known Member

    Joined:
    Jan 11, 2004
    Messages:
    359
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Roswell, GA
    I know, I said I got it in my last post. :rolleyes:
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  11. mickalo

    mickalo Well-Known Member

    Joined:
    Apr 16, 2002
    Messages:
    782
    Likes Received:
    5
    Trophy Points:
    318
    Location:
    N.W. Iowa
    I'm wondering if any one that upgraded Perl with the new version, did you noticed that you had the same additional Perl modules that may have been installed, with pervious version.

    We added several Perl modules, via the WHM, and was wondering if these additional modules will still available after the upgraded or do we need to go back and reinstall all these additional modules ?

    Thx's
    Mickalo
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  12. katmai

    katmai Well-Known Member

    Joined:
    Mar 13, 2006
    Messages:
    537
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    Brno, Czech Republic
    perl upgraded by cpanel.net staff to 5.8.8 (not too happy about it as they did not ask me) but mind that

    modules are gone, and i noticed

    2007-03-29 13:46:36 1HWt5H-0000C0-Ut failed to expand condition "${perl{checkbx_deliver}{$domain}{$local_part}}" for virtual_boxtraper_user router: Undefined subroutine &main::checkbx_deliver called.

    2007-03-29 13:46:36 1HWt5H-0000C0-Ut failed to expand condition "${perl{checkuserbx}{$local_part}}" for boxtrapper_localuser router: Undefined subroutine &main::checkuserbx called.


    in /var/log/exim_mainlog

    i did upcp --force, did eximup --force, courierup --force

    i am tired, and i already wrote in another post i have this issue, but ... nobody had any infos/ideas

    running centos 4.4 on latest edge
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  13. carluk

    carluk Well-Known Member

    Joined:
    Sep 2, 2003
    Messages:
    162
    Likes Received:
    0
    Trophy Points:
    166
    Try /usr/local/cpanel/bin/checkperlmodules
    Also make sure boxtrapper is disabled and refences to boxtrapper removed from /etc/exim.conf
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  14. katmai

    katmai Well-Known Member

    Joined:
    Mar 13, 2006
    Messages:
    537
    Likes Received:
    1
    Trophy Points:
    168
    Location:
    Brno, Czech Republic
    removed. both from exim.conf and outgoing_conf error free. thanks.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  15. Valuehosted

    Valuehosted Well-Known Member

    Joined:
    Dec 12, 2002
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Sweden
    how do I compile and update perl 5.8.8 ?

    Thanks,

    Tony
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  16. Valuehosted

    Valuehosted Well-Known Member

    Joined:
    Dec 12, 2002
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Sweden
    found a post on how to do it. Thank you!
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  17. Metro2

    Metro2 Well-Known Member

    Joined:
    May 24, 2006
    Messages:
    414
    Likes Received:
    24
    Trophy Points:
    168
    Location:
    USA
    cPanel Access Level:
    Root Administrator
    Care to share the link? I could use some help too...
     
  18. cooldude7273

    cooldude7273 Well-Known Member

    Joined:
    Jan 11, 2004
    Messages:
    359
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Roswell, GA
    I'll do it for you guys if you want - free, but donations accepted. ;)

    I've done it on my server and it successfully works 100%
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  19. Valuehosted

    Valuehosted Well-Known Member

    Joined:
    Dec 12, 2002
    Messages:
    124
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Sweden
    What I did was...

    login as root and cd to
    /root
    fetch http://layer1.cpanel.net/perl587installer.tar.gz
    tar xfz perl588installer.tar.gz
    cd perl588installer
    ./install

    Then run the following to make sure your mods are up to date.


    /usr/local/cpanel/bin/checkperlmodules


    --Tone
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
  20. cooldude7273

    cooldude7273 Well-Known Member

    Joined:
    Jan 11, 2004
    Messages:
    359
    Likes Received:
    0
    Trophy Points:
    166
    Location:
    Roswell, GA
    Personally, I'd modify that first to make sure you download the right version with as well as cleaning up what you downloaded and removing the cached version files in cPanel so they will update to show 5.8.8 instead of what you may have installed already:

    What I did was...

    Code:
    cd /
    wget http://layer1.cpanel.net/perl588installer.tar.gz
    tar -xvzf perl588installer.tar.gz
    cd ./perl588installer
    ./install
    cd /
    rm -rf ./perl588installer
    rm ./perl588installer.tar.gz
    rm -f /home/*/.cpanel-datastore/_usr_bin_perl_-v
    /scripts/upcp --force
    That's how I did it. :)

    Just follow those steps above or contact me for help.
     
    Stop hovering to collapse... Click to collapse... Hover to expand... Click to expand...
    #20 cooldude7273, May 12, 2007
    Last edited: May 13, 2007
Loading...

Share This Page

  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice