The Community Forums

Interact with an entire community of cPanel & WHM users!
  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.

Perl and MailScanner

Discussion in 'E-mail Discussions' started by SiMka, Jan 2, 2006.

  1. SiMka

    SiMka Active Member

    Joined:
    Mar 12, 2005
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    I have problems with perl5.8.6 and perl5.8.7 and MailScanner.

    When I use the one of the perl versions then the MailScanner itself works fine, but none of the emails dont go users inboxes. When I downgrade to perl5.8.5 then MailScanner fails every 10-15 seconds, BUT users can get their e-mails.

    Anybody knows what causes this problem?
     
  2. chirpy

    chirpy Well-Known Member

    Joined:
    Jun 15, 2002
    Messages:
    13,475
    Likes Received:
    20
    Trophy Points:
    38
    Location:
    Go on, have a guess
    The cause is likely your configuration of your OS update procedure. See the following thread:
    http://forums.cpanel.net/showthread.php?t=48047

    I'd suggest that you put it back to perl v5.8.7, make sure that the following runs cleanly:

    /scripts/rpmup

    Then reinstall/upgrade MailScanner to make sure that you have all the correct perl modules installed.
     
  3. SiMka

    SiMka Active Member

    Joined:
    Mar 12, 2005
    Messages:
    36
    Likes Received:
    0
    Trophy Points:
    6
    Great.

    Thank You.
    After running the /scripts/rpmup and doing the fresh MailScanner install it work perfectly.
     
Loading...

Share This Page